RangeRovers.net Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
42 Posts
I am supposed to take delivery of my '18 HSE at the end of the month and this issue has me concerned. I've spent too much time trying to find how common this problem is but, there obviously isn't much data on the full size. Lots of problems with the RRS. I would have thought that the Velar would have many of the same issues but, surprisingly, I can't find a site that discusses dual screen issues.

I'm keeping my fingers crossed that the majority of problems are associated with the RRS and that, perhaps, LR has improved the system for the full size.

So, perhaps an informal poll:

For those of you who have taken delivery of a new '18 full size, have you had this issue with the dual monitor reboot/locking?
 

·
SUPER MODERATOR
Joined
·
27,783 Posts
Discussion Starter #3
Just because they look the same does not mean they operate the same or have the same components and software.
 

·
Registered
Joined
·
44 Posts
For those of you who have taken delivery of a new '18 full size, have you had this issue with the dual monitor reboot/locking?
I’ve had mine over a week and haven’t had a single problem with the dual screens. Very little lag as well... works like a charm!
 

·
Registered
Joined
·
42 Posts
I sent an email to my dealer and this is the response from his service guy:

" Based on my experience and collaborating with tech-line regarding this issue on the new 2018MY RR's, the solution has been to perform software updates on the ICDMA and ICDM (Interactive Control Display Modules A and B). These are the two touchscreen displays used for InControl Touch Pro Duo.


Our 2018 RR demo had this issue upon delivery. The problem was resolved after performing the software updates mentioned.


Hope this helps,"
 

·
Premium Member
Joined
·
1,825 Posts
however, another guy at the 494 forum says he was told this (or another) update corrupted the computer firmware and it needs to be hardware replaced.

either way, mine is a V8 supercharged full size and is back in the shop with this issue after less than 48 hours of ownership.
 

·
Registered
Joined
·
42 Posts
however, another guy at the 494 forum says he was told this (or another) update corrupted the computer firmware and it needs to be hardware replaced.

either way, mine is a V8 supercharged full size and is back in the shop with this issue after less than 48 hours of ownership.
Bummer. I would love to know how things work out.
 

·
Premium Member
Joined
·
1,825 Posts
Can you do me a favor? Can you go to your NAV settings -> Application Details and put here what App Version your car has? Thanks. Looking for something like this:

IMG_0318.jpg
 

·
Premium Member
Joined
·
1,825 Posts
why it is sideways I have no idea. If you right click the image and choose open in new tab, it should look proper.
 

·
Registered
2019-2021 Range Rover MkIV / L405
Joined
·
28 Posts
I've had my 18 LWB for a few weeks now and I haven't had any issues with the screens, no rebooting, etc. I can post a picture of the app version later today, if that's helpful to anyone.
 
1 - 13 of 13 Posts
Top