RangeRovers.net Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Anyone having issues where the backup camera randomly stops working on their my18 RRS? Occasionally when I'm backing up generic pictures of the car shows up showing the 360 parking sensor warning and option to hit the camera button or settings. Nothing happens when I hit the camera button and settings just gives me the option if I want to automatically turn on 360 view and turn lines. Also if I go back to the home page and hit the camera button it says camera not available. After restarting the car it goes back to normal. I'm going to bring it to the dealer but anyone else have this prob?
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
298 Posts
Lots of others having the problem very similar to yours.
If you search you’ll find lots of other posts.



Sent from my iPhone using Tapatalk
 

·
Registered
2019-2021 Range Rover Sport
Joined
·
26 Posts
Been working very closely with my dealership. I can confirm that the latest software update (currently in beta, supposed to be publicly released in July), fixed this issue. Hang tight, a solution is on the way!
 

·
Registered
Joined
·
102 Posts
Good to hear that an update is on the way - hopefully the one that was highlighted in the 405 forum that shows over-the-air software update capabilities. Do let the group know once this is publicly avalaible so we can all run to the dealers and get these issues fixed, hopefully for good.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Lots of others having the problem very similar to yours.
If you search you’ll find lots of other posts.



Sent from my iPhone using Tapatalk
gotcha, so this is most likely a software and not hardware issue then from what I'm reading. I guess I'll cancel my appointment to service then and hang tight for a software fix. Thanks for the heads up!
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
298 Posts
Definitely a software issue.
I did get a couple of updates and it did help a lot. Before, it would happen like 50% of the time. Now, I say it happens less than 10% of the time.

But so annoying, I’ve become so reliant on-the cameras, that I have trouble without them.


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
69 Posts
Hit this last week, definitely felt like a software issue - just had it let it reset itself. Hopefully the July patch fixes some other quirks I noticed as well (or I may have to report them) - the full map view on the gauge cluster doesn't always show up on startup unless I toggle the radio power, and I really wished the nav searching would be fast or at least cache...my 15 Evoque had faster auto completes than this (it takes at least a few seconds or more just to accept the first digit of the zip code).
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
294 Posts
Add me to the list of people with this problem. I have pretty old software on the car I just took delivery of Friday, I too am hopeful the new patch fixes things.
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
294 Posts
The latest software fixed 100% of my issues.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
69 Posts
The latest software fixed 100% of my issues.
Awesome. Is there a way to check which version it's on? I just picked up my SVR at the beginning of June - I assume there's no way it would have this patch.

By the way, has anyone had their camera view switch to a diagnostic mode? Where it shows a bios looking menu of about 9 options? Not clickable of course, but kinda sad and hilarious at the same time.
 

·
Registered
Joined
·
25 Posts
Good to hear that an update is on the way - hopefully the one that was highlighted in the 405 forum that shows over-the-air software update capabilities. Do let the group know once this is publicly avalaible so we can all run to the dealers and get these issues fixed, hopefully for good.
i searched but could not find any mention of this in 405 forums.
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
294 Posts
Yep I saw the diagnostics screen as well.

To check your version go to Navigation > Settings > Nav Settings > App Details.

From what I was told the July update I have came out about July 8. It was the largest update they ever applied, it took almost 24 hours including 3 retries.

Yes over the air updates seem possible now.







 

·
Registered
Joined
·
42 Posts
Discussion Starter #16
Got the update, so far so good. Time will tell. Also seemed to fix the overly sensitive parking sensors. It would always go off with a warning of getting something close on the passenger side whenever I back out of my driveway even though nothing was around. It stopped doing that now. Now if I could ever get the 4g to work smh
 

·
Registered
Joined
·
78 Posts
I just scheduled my appointment for next Wednesday to get my software updated. The dealer didn't show my VIN required one, but he said to bring it in to have them confirm.

Just had my 1st camera "blackout" yesterday. Also some weird thing with playing my iPod Touch where it wouldn't recognize it or let me switch devices. Nothing major, but being I've only had the car 10 days, I need the updated software before this becomes a repeated issue.

I know each place is different, but anyone happen to know how long it took for them to complete the update? Hoping I can drop it off at my 9:30am appointment time and get it updated within the same day.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
69 Posts
Currently in talks with my dealer to get this updated. Crossing my fingers that it's not a 24 hour job.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
19 Posts
Brought mine in yesterday afternoon after speaking with the gm at my dealership about my camera issues. He agreed to update to the latest software version. It was ready earlier today, but I wasn’t able to pick it up before they closed.
 

·
Registered
Joined
·
25 Posts
You guys are lucky if you got the update done already. i took it in last monday with the rear camera issues among others, and they still haven't been able to get it to update yet. they claim the servers must be overloaded.
 
1 - 20 of 34 Posts
Top