RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
Banned
Joined
·
107 Posts
Discussion Starter #1
All,

I've recently wanted to use this socket to power up a dashcam, it is dead. I've checked fuse 60 behind the glovebox and visually it is fine, but swapped it out anyway and retested. Socket still dead, even with the ignition on. So, anybody ever removed this, or know how?

The other issue is that the genuine, OEM lighter I bought seems not to want to work in ANY of the sockets in the car. So that's neither of the rears, or either of the fronts. Either JLR don't want you doing anything other than using them for accessory power, or the lighter I bought is a dud.

Any ideas on either issue please?
 

·
SUPER MODERATOR
Joined
·
27,710 Posts
Are you actually testing for voltage or just plugging a lighter in each socket? It's very suspicious that all sockets are dead. Side note, visually inspecting a fuse is actually pretty useless. Get out a multimeter or at a minimum a test light.
 

·
Banned
Joined
·
107 Posts
Discussion Starter #3
I was not clear. All the sockets other than the cup holder socket work if you use a USB charger in them. I skipped the fuse test and simply replaced it with a brand new, known good fuse.
 

·
Banned
Joined
·
107 Posts
Discussion Starter #4
Resolved the dead cigarette lighter socket by replacing the correct fuse! Fuse 63, not 60... 63 is an absolute horror to reach.

However the cigarette lighter itself does not work. Push it down, and it just pops right up, so never heats.
 
1 - 9 of 9 Posts
Top