RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
So my10 had 0 issues. In a winter low coolant light came up so I added to the mark. 2 weeks later low coolant light came up again. I took the car to Indy and he pressurized the system for 30 minutes and he could not find any leaks. Also system would hold pressure without any problems. He checked all the houses and could not find ny leaks. Car dose not smoke more than usual. Now check engine came up and restricted performance. After engine temp gets up restricted performance disappears. Checked codes and I have misfire on 6 cylinder. He checked that and said most likely it is injector. I am thinking if changing the spark plug first but not sure if all these related.


So main question is there my coolant disappears and could it all be related?
 

·
Registered
Joined
·
1 Posts
Did you find out what was wrong?
I'm having a very similar problem with my 2006 RRS. It's heading to the mechanics tomorrow and I'm curious to see what they say. I hope it's not a blown head gasket!
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
Sadly the OP is a common type that posts a couple times a year with an issue and never follows up... and disappears until their next issue.

the 2006 and 2010 cooling systems are quite different. Early Sports had issues with the recovery tanks separating at the seams. Before you hit up a mechanic go out and look for discolouration along the the sides of your "burp" tank. It's often hard to see but may present as white powder or streaks. It is as simple and cheap DIY that takes about 10 minutes. You can easily replace the tank yourself if you see signs of the tank leaking. It even comes with a new level sensor for under $70 here in the States.
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
I guess I should add that later Sports had issues with the secondary bleeding valves seeping. If not replaced they would crack then completely fail and all coolant would be lost. In the early stages of seeping the system would still show no real loss of pressure. That could have been Igor's issue. His restricted performance error was most likely due to a backwards wired secondary coolant pump... TSB issued. However since he has nor Rover info in his signature we will never know. :lol:
 

·
Registered
Joined
·
10 Posts
I guess I should add that later Sports had issues with the secondary bleeding valves seeping. If not replaced they would crack then completely fail and all coolant would be lost. In the early stages of seeping the system would still show no real loss of pressure. That could have been Igor's issue. His restricted performance error was most likely due to a backwards wired secondary coolant pump... TSB issued. However since he has nor Rover info in his signature we will never know. :lol:
Where do I find this secondary bleeding valve you refer to here? I'm curious to know if this could be the issue on my wife's 07 RR SSC.

-Andy
 
1 - 6 of 6 Posts
Top