RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
2010-2012 Range Rover Sport
Joined
·
472 Posts
Discussion Starter #1
1) Starting Issue: Ten days ago, vehicle would not start after being unused for 5 days. Called roadside assistance. They connected an auxiliary jumper battery and it still would not start. Let sit for five minutes and then it did. No problem since then. Is there an underlying issue?
2) #Q093: please complete SERVICE ACTION campaign #Q093.
3) Front end shimmy: This is a very common problem with these vehicles. Stock tires and wheels did it after vehicle had about 1,000 or so miles. Stock wheels and expensive Michelin snow tires did it. My new wheels and stock Michelin tires now do it too and they are dynamically balanced. Tire balance is not the issue. Issue occurs between 50-70 mph under acceleration or up a hill; minimal shimmy at this speed going down a hill.
a. Is there a fix to this issue?
b. Can you please do something?
4) Driver side windshield wiper mount: It is cracked and broken where the assembly connects to the arm and has been this way since I can remember.
5) Noise from rear passenger door or seat area: Seems to be a lot of racket coming from there over sizeable bumps almost like door or seat is loose or a component is.
6) Drive side seat leg room: The passenger seat goes back about 1.5 inches more than the driver’s seat. Please adjust or fix driver’s side seat so it travels as far back as the passenger seat.

Thank You!
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
472 Posts
Discussion Starter #3
kstatenupe said:
You forgot to add - Ask for a MY09 or MY10 RRS for a loaner. You know your truck is gonna be in the shop for a while.
I'm actually dropping off before i catch a plane for three days....I'll request a loaner if its not ready Saturday! maybe a LRRR - SC
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
Nope, I think you have covered everything.

Godspeed.
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
83 Posts
I have about 19,000 miles on my 2010 rrs. I may have had a few more problems that may be of help.

1. Front brake pads and rotors wore out at 9000 miles. I was told I had hotspots.
2. Make sure they follow 2010 procedure for oil change. I had to go back because I was told they did something wrong an realized after I left.
3. The service action thing may solve your seat issue. They had to reprogram my computer to get the auto seat raise/lower on entry/exit to work.
4. Have them check alignment.
5. Do you have condensation in head/taillights after wash or rain?
6. Does your car lean when parked?
 

·
Registered
Joined
·
270 Posts
scuderiaRR said:
I have about 19,000 miles on my 2010 rrs. I may have had a few more problems that may be of help.

1. Front brake pads and rotors wore out at 9000 miles. I was told I had hotspots.
2. Make sure they follow 2010 procedure for oil change. I had to go back because I was told they did something wrong an realized after I left.
3. The service action thing may solve your seat issue. They had to reprogram my computer to get the auto seat raise/lower on entry/exit to work.
4. Have them check alignment.
5. Do you have condensation in head/taillights after wash or rain?
6. Does your car lean when parked?
And I thought I had a lot of miles on my 09. Hit 20000 last week. Im a couple of weeks shy of having my truck for a year.
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
472 Posts
Discussion Starter #8
Harrisburg Land Rover RULES!

BWB RRS HSE said:
1) Starting Issue: Ten days ago, vehicle would not start after being unused for 5 days. Called roadside assistance. They connected an auxiliary jumper battery and it still would not start. Let sit for five minutes and then it did. No problem since then. Is there an underlying issue?
Full check-out, could not replicate problem - most likley the computer stayed on and drained battery.
BWB RRS HSE said:
2) #Q093: please complete SERVICE ACTION campaign #Q093.
DONE!
BWB RRS HSE said:
3) Front end shimmy: This is a very common problem with these vehicles. Stock tires and wheels did it after vehicle had about 1,000 or so miles. Stock wheels and expensive Michelin snow tires did it. My new wheels and stock Michelin tires now do it too and they are dynamically balanced. Tire balance is not the issue. Issue occurs between 50-70 mph under acceleration or up a hill; minimal shimmy at this speed going down a hill.
a. Is there a fix to this issue?
b. Can you please do something?
They took all four tires/wheels off and Hunter Roadforced them and found out that all the stock Michelin tires were out of round to some degree!!!! Put the two best on the front of the vehicle and the shimmy is almost gone...the improvment is significant. The difference is night and day!
BWB RRS HSE said:
4) Driver side windshield wiper mount: It is cracked and broken where the assembly connects to the arm and has been this way since I can remember.
Fixed!
BWB RRS HSE said:
5) Noise from rear passenger door or seat area: Seems to be a lot of racket coming from there over sizeable bumps almost like door or seat is loose or a component is.
Could not replicate.
BWB RRS HSE said:
6) Drive side seat leg room: The passenger seat goes back about 1.5 inches more than the driver’s seat. Please adjust or fix driver’s side seat so it travels as far back as the passenger seat.
Fixed!
 
1 - 8 of 8 Posts
Top