RangeRovers.net Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
I scored a cheap Great Divide truck the other month for under a grand. she runs... but doesn't stop! I noticed a lot of water in the engine oil so i ran a bunch of ATF in there and new oil and sea foam. trying to run it a lot to clean it all out of there. I will drop the pan later and take the valve covers off to inspect more.

When I got it the engine wasn't idling too well because all the vacuum hoses were clogged up and cracked. looked like someone blew snot in all the hoses. Cleaned those up and she ran a lot better!

I am thinking about bypassing the ABS because the ABS and brake light are both on and the peddle goes to the floor. So I need to tackle that next. If I bypass the ABS all I need to do is get a servo and master cylinder form a 87-88 truck right?

Some questions:
The metal sunroof is missing... anyone have one they can sell me? or know where I can get one for cheap?
Anyone have a Great Divide OEM bumper for my to buy?

I am going to put it on Defender 110 rims and some 31" BG Goodrich ATs and have it be my Expo truck. should look nice when im done with it.

Pics:
http://www.abrahamthen.com/Other/njrove ... 9532_FBXuA


 

·
Registered
Joined
·
21 Posts
Very nice, i like the rims, if you decide to sell them LMK
 

·
Registered
Joined
·
106 Posts
You may want to try swapping the ABS relay first. Mine had brake lights on and pedal to the floor when I got it, 1 $30 relay later and all was well again. Just a thought.
 

·
FOUNDING MEMBER
Joined
·
382 Posts
Can't help about the brakes but forwarded the link to this thread to a couple of friends who might be able to help about the sun roof and bumper. Might be just as well that you plan non-stock wheels as those on it when you bought it are the wrong wheels for a GDE anyway.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #6
Thanks for the comments! yeah I do really like those 95 style rims but the look I am going for needs the NAS 110 or ROW 110 rims on it. I have the rims, just need to sand blast and paint them up to match.

LebaneseShowoff - I will definitely sell you the rims when i get the new rims and tires on.

Granny - thanks again. Im sick of looking at that metal roof every time I sit inside.

HUMMER H1 - lets talk about the bumper. I will PM you later.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #7
So I did a bunch of work on the truck this weekend and put in a 2nd hand ABS pump. I noticed the pump would run every push of the brake so I thought my accumulator was gone. so i bleed the ABS pump because there was air in it, and I think I bleed the accumulator right (sudden gush of air and brake fluid all over because it was under pressure) and then it seemed to work better. ABS pump stopped running every push of the brake. I didn't even bleed the brake lines or replace the more than shot front rotors and pads. Took it for a spin and it stopped real nice!

I love it when the truck works. runs smooth too. next on the list is either front diff or front driveshaft is about to go. I hear so rattle/bearing noise as i let off the gas at speed. I hope its not the t-case because I know the diff is a simple swap :)

Anyone has a metal sunroof sliding piece? I just have the bare metal roof to look at and its ugly.
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
52 Posts
Nice find! Congratulations! Do you know how many GDE's were built?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #9
From our rangerovers.net site:

"A limited edition of 400 were made according to press releases and only 400 have the numbered plaques in the door jambs. A total of 409 GDE models were built (the NAS parts manual lists all the VIN #s). The extra 9 GDEs were used for promotional purposes by RRNA. One of the 9 was loaned to the Death Valley Park Rangers for patrol duties and had the optional factory winch hidden under the front bumper, ranger decals, and a red and blue highway patrol style light bar on the roof."

Its a cool limited edition truck and I really like it so far. I have been fixing it up and so far so good. I am missing some pieces and need to get them.

Also I have this problem with the tail lights. If the truck is running the tail lights (maybe not the tail lights but the rear fog lights?) are on even if the headlights aren't on. and the brake light will not illuminate if the pedal is pushed. You guys think its a bad ground back there? also one of my headlights is out, could this be causeing that?
 

·
Registered
Joined
·
334 Posts
I'd replace the burned-out headlight first, I've heard of interesting things going on with the lights even if one bulb/light is burned. Shame you have to replace the whole thing though :(
 

·
Registered
Joined
·
66 Posts
Discussion Starter #11
james said:
I'd replace the burned-out headlight first, I've heard of interesting things going on with the lights even if one bulb/light is burned. Shame you have to replace the whole thing though :(
Wierd thing happen. I replaced the one that was gone and I switched on the lights and both came on super low. like very, very low light coming from them. so i drove it around and the bumps must of shook it up and the new beam came on full light and the other original light went out. I think there is a grownding issue with the lights.
 

·
Registered
Joined
·
106 Posts
I've heard (but not experienced) that one should change both headlamps at the same time because differences between the bulbs could cause problems. I've always just changed the one that is out and never had a problem, but I've been told you should replace both from a few different sources. Perhaps you're right and its a grounding issue, I'd be interested to know the outcome when you figure it out.
 

·
Registered
Joined
·
1 Posts
That's great that you're restoring one the great AND RARE edition of Range Rover!!

I have one as well and it's pretty much fully restored!!

I wonder how many of the GDEs are still registered still.....

Is there a way to find out? Maybe through DMV??

My GDE is performing flawlessly with one minor issue.....It guzzles gas like one would drink hot chocolate in an ice cave!!

I'm talking like 8mpg....I've tried/checked pretty much everything like O2 Sensor, New air filter, New fuel filter, checked fuel lines, checke fuel injectors.....

It doesn't smell like gas from the exhaust pipe which probably means it's not the "running rich" issue.....Anyone have any other suggestions??

But quite frankly, it really doesn't matter that it gives me 8mpg....I STILL LOVE THIS TONKY TOY!!!
 

Attachments

1 - 13 of 13 Posts
Top