RangeRovers.net Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey guys - so I've got a 2006 RRS and for the past 4 years I've heard "i can't hear you" "are you in a wind tunnel" "I hear my voice". I tried a lot things recommended on the site - including turning down the volume, etc. Even with the windows/sunroof closed, talking on the highway isn't even an option.

Yesterday, I was in my friends 3 Series BMW for a four drive trip for a business trip. Nearly the whole way up and back, we were on the phone with 10 or so different people. It sounded great and not one person complained and he said he has only had one or two people ask about the connection (it's a 2009 btw).....

Am I the one fed up with my Bluetooth? The dealership continues to tell me that it's functioning properly. What is your experience? I'm hopeful that some people say that there's is perfect and that it is, in effect, just my Bluetooth that needs to be replaced....

Thanks in advance!
 

·
Registered
Joined
·
74 Posts
Mine works great if all I want to do is be a passive participant on a conf call. If I want to say something, forget it. You can't hear me.

I've got a 2008.
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
126 Posts
I know there is an upgrade you can pay for ... search around it is here.

I dont understand how they are so far behind with the technology compared to Lexus, etc... all these units have to be coming from the same sweatshop.. why not add the features...

IE .. phonebook option, dialing from screen, maint on screen, calendar on screen, etc, etc..
 

·
Registered
Joined
·
22 Posts
I have an 06 as well I complained at my last check up and they said the upgraded my software but people yell at me all the time that they can't hear me or the connection sucks. Its not your truck its all of them. I don't think the upgrade will help audio it will give you some extra bells and whistles like haveing your phone book on your radio but thats not going to solve this prob. Sorry man I have an 3gs iphone as well if that helps. If you figure anything out please post love to hear an answer
 

·
Registered
Joined
·
270 Posts
I have an 09, and i have never had any probs on the BT side of things. I normally have to wait until I get past my sons school for it to sound right though. Obviously thats on the phone/service side. What phone are you using? I have a BB Bold.
 

·
Registered
Joined
·
521 Posts
I just set mine up this morning and was on a few calls. No problems.

Using a 3G iPhone.
 

·
Registered
Joined
·
318 Posts
beachfront said:
I know there is an upgrade you can pay for ... search around it is here.

I dont understand how they are so far behind with the technology compared to Lexus, etc... all these units have to be coming from the same sweatshop.. why not add the features...

IE .. phonebook option, dialing from screen, maint on screen, calendar on screen, etc, etc..
Mine works great as far as hearing and speaking to people. I did recently just get the latest upgrade to the system, before it wouldn't even pair with my Tour!! Still can't get addresses to show up though.
 

·
Registered
Joined
·
14 Posts
I have an 06 with the newest upgrade and I am using an Iphone 3GS and it works great, phonebook and all.
 

·
Registered
Joined
·
423 Posts
i had an 06 sport, i have an 07 HSE with upgrade and its crap...same thing about being in a wind tunnel, crackling, cant even carry a conversation.
how cld it be it works fine for some and terrible for others. ive tried motorola phones, 4 blackberries, and an iphone. its so bad im going to have a parrot system installed.

does anyone know if they changed the system they use? i know 06 and 07 are crap. if they did change what year was it?
 

·
Registered
Joined
·
115 Posts
I have an '07 HSE since new, no Bluetooth upgrades. I've used both a BB Pearl and now an Iphone 3GS. I've never had a problem with 'wind tunnel ' or people hearing me. Most people think I am still in the office ( hee, hee). I like the fact that you can turn up or down the receiving volume with the wheel buttons. Maybe it is you phone. The Iphone connects more reliably than the BB on entry to the car.
In rental cars I use a Blueant V1, voice activated, ear piece with the Iphone. The Range Rover works just as well as the ear piece. When I get back into my RR, the RR picks up the bluetooth and the phone drops the Blueant automatically.
Maybe Rover got a bunch of bad mic's, or you have a bad sunroof seal which is being picked up by the mic.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
bop08 said:
Maybe Rover got a bunch of bad mic's, or you have a bad sunroof seal which is being picked up by the mic.
Bingo. Or perhaps the microphone is flipped or points in the wrong direction inside the overhead console where it is mounted? I never had problems with my 2006 PTI either, before and after software upgrade reception on both ends has always been clear. Currently using with a Moto Droid but my previous BlackBerry was equally good (except for an annoying static "discharge" that occurred every time Bluetooth would connect me to an outgoing call.)
 

·
Registered
Joined
·
423 Posts
ok im not the smartest guy in the world but i cant find the microphone. can u post a pic of exactly where it is and what it looks like?
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
The mic is mounted on the overhead console to the left of the sunroof open/close buttons.

See # 1 in diagram: [attachment=2:lbeooa8q]PTIdiag.jpg[/attachment:lbeooa8q]
Microphone:[attachment=1:lbeooa8q]mic.jpg[/attachment:lbeooa8q]

It's jammed in its mounting bracket pretty good, but easy to see once you open up the console. To get to it, you can use the same directions for mounting a radar detector in this thread: viewtopic.php?f=5&t=25832
[attachment=0:lbeooa8q]Mikepic.jpg[/attachment:lbeooa8q]
 

Attachments

·
Registered
Joined
·
213 Posts
I have an 06 sport sc and I agree it sucks. I can hear others just fine, however I get complaints from other that they get echo. I had it at the shop recently and told them, but they say nothing is wrong. I wonder if it may be the incompatibility that LR mentions with the iPhone 3GS... But then again some people don't have any problems using their 3GS. I can't see why it would be the phone at fault as I had it bluetoothed with my previous car and everythig was fine.
 

·
Registered
Joined
·
1 Posts
Hey guys,

I've got an '08 Sport HSE and have been using my iPhone 3G on it for about a year now.

Just recently however, the bluetooth signal in the Rover has become EXTREMELY distorted and sounds like a "bad cell signal" on my end, however my caller can still hear me just fine, moreover when I pick up the handset to use it by ear, the conversation goes clear.

I've taken it to the dealer complaining of the issue and they said everything was up to par on the cars end so it must be my phone.

NOTE: I also paired it with the MB C300 loaner they gave me and was also having the same issue.

Fact is, anyone else having this issue with their phone???

Bought my 3G phone about 2 years ago
 

·
Administrator
Joined
·
27,802 Posts
:? Well if you are having the same issue in two cars I doubt if it would be the cars. Have you tried iPhone support or an iPhone forum?
 
1 - 20 of 20 Posts
Top