Range Rovers Forum banner
1 - 2 of 2 Posts

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
4 Posts
Discussion Starter · #1 ·
The fuel pump failed on my '06 Range Rover HSE and was replaced with an Atlantic British aftermarket. That one failed after a few weeks and was replaced under a part warranty. The second one failed after a month or so and a trip cross country the second replacement failed also. Each time the engine stopped at suddenly and would not restart. After the first and second replacement, the fuel gauge was erratic; not reliable. The third time I was not st a Land Rover dealer and had a replacement by Worldpack. This one has continued working fine but the fuel gauge is still erratic; shows three quarters full, but after a restart it shows nearly empty, and vice versa.
Any ideas? Seems like an electrical problem causing the failure all three times? Thanks for any input.
 

·
Registered
Joined
·
1,785 Posts
on the gage there is some mention of ignition on/off and fuel level changes between removal and replacement of the pump. I changed the pump only and did not change the fuel level or turn the key on while the pump was disconnected. it seems to be ok. i have read that pump failure results if the tank is not cleaned and the debris of the pump failure remains. Our pump was noisy and had not failed when i changed it and all has been well once i got the fuel line secured properly. Not sure what electrical issue could destroy all those pumps. the pump i got was a piedmont-made in poland-but that is supposed to be an original brands. Seems like a lot are made in china
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top