RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
well, got it up and running, now when i start it up, oil light goes out as it should, then, after about 10 seconds comes on, any ideas,
i was thinking possible oil pump

any ideas would be much appreciated
 

·
Registered
Joined
·
186 Posts
Perhaps the pickup tube in the sump has moved, and it pulls the oil level down on start up to a point where it draws air. Can you attach a gauge in lieu of the sending unit?
 

·
Registered
Joined
·
56 Posts
Discussion Starter #3
yeah, good idea, i was wondering if the seal from the pick up, to the pump maybe dislodged, sump off again then
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
865 Posts
I dont see a mention of new oil pressure switch, cheap to replace and see.

Oil pressure regulator prephaps..

Low on oil, stupid I know and I would recheck.

Wrong or bad oil filter, to restrictive...

Oil cooler pipe collapsing.

Oil cooler blocked...if engine blew and required complete rebuild I would remove oil cooler and have it cleaned out.

Oil filters have a bypass and metal could easily have gone through to cause more problems
Every engine rebuild no matter what make of vehicle that is ffitted with a engine oil cooler like the P38 should be cleaned out
 

·
Registered
Joined
·
56 Posts
Discussion Starter #5
hi, engine didn't blow, was more of a error on my behalf (cam timing wrong) deffo has low oil pressure, but i will change the switch, and the oil filter again, i did clean out the oil cooler when the engine was out.

well, i'm starting to know these engines pretty well now any way

might just get a new oil pump anyway, whilst i got it off
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,851 Posts
Hi

Check oil pressure relief valve. It might not close properly causing the lack of oil pressure.

Regards

Jos
 

·
Registered
Joined
·
56 Posts
Discussion Starter #7
stripped it out again today, found the oil pump outer gear broke completly half, so i think i have found the problem, any 1 tried the oil pump repair kit, like the one sold by island 4x4, here seems ok, alot cheaper than a new front cover
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
865 Posts
Glad you found the problem..cover should be ok to re-use if its not damaged
 
1 - 8 of 8 Posts
Top