RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
1 Posts
Discussion Starter #1
metalmicky
have seen similar problems to mine on this site but not sure where to go nexted i know 80% of faults are electrical problems
3.6 v8 twin turbo diesel vogue se 2007
car started to go into limp mode with engine system fault alarm on the dash and special systems alarm on the nav screen and the all terrain light goes out on the centre consel
spent 1400 euro,s up to now at the local garage and fault still the same
we fitted the best battery possible
checked the multiplug on the transfer box no rear diff actuator fitted
replaced 4 tyres tracking done and 2 worn front suspension arms fitted so he could do a reset on the steering angle sensor
about 14 codes come in and all can be reset apart from u0402/94 u0416/94
i can get out of limp mode by pulling over switching off and restarting the car and if i drive below 2000 revs the car can be driven with only the engine system fault warning coming in for approx 20 seconds then resets without affecting the motor, anything above 2000 revs bang limp mode
he is now thinking of replacing the vdc module or the abs module in the engine bay
i need to know if he is going in the right direction as the next few bits will take us over 2000 euro,s with no garantee to fix the car
 

·
Registered
Joined
·
1 Posts
metalmicky
have seen similar problems to mine on this site but not sure where to go nexted i know 80% of faults are electrical problems
3.6 v8 twin turbo diesel vogue se 2007
car started to go into limp mode with engine system fault alarm on the dash and special systems alarm on the nav screen and the all terrain light goes out on the centre consel
spent 1400 euro,s up to now at the local garage and fault still the same
we fitted the best battery possible
checked the multiplug on the transfer box no rear diff actuator fitted
replaced 4 tyres tracking done and 2 worn front suspension arms fitted so he could do a reset on the steering angle sensor
about 14 codes come in and all can be reset apart from u0402/94 u0416/94
i can get out of limp mode by pulling over switching off and restarting the car and if i drive below 2000 revs the car can be driven with only the engine system fault warning coming in for approx 20 seconds then resets without affecting the motor, anything above 2000 revs bang limp mode
he is now thinking of replacing the vdc module or the abs module in the engine bay
i need to know if he is going in the right direction as the next few bits will take us over 2000 euro,s with no garantee to fix the car
hi did you cure the fault thanks as I am having exactly the same fault
Any information would help thanks
 
1 - 2 of 2 Posts
Top