RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Hello I just bought a 1998 RR HSE with 131000 and. Drove back from South Dakota no problems when I got Home changed oil( was black and grimy) and put in Mobil 1 my mechanic gave me a oil cleaner to help with any build up and clean out.Headed back to south Dakota for vacation got to South Dakota and this is when the lifters sound started to tick only after it warmed up and when I was idleing not when I accelerated. I also saw a small leak at the front main seal and another mechanic confirm the small leak.My question is I'm having the front seal replace and the lifter cleaned and looked at how bad is this really and how often do the lifters need to be changed or rocker arms if this can't be fixed through a good cleaning? Also all the mechanics told me who I ask that the lifters were no big deal is this true? Or should I just go to a heavier oil since I am using a 5w30. Any help would be much appreciated. Thanks
 

·
JACK'S GRANDAD
Joined
·
9,244 Posts
I have heard of the "cleaners" and synthetic oil having ill effects on a motor that has ran normal oil all its life.
I know that in other vehicles, going to synthetic shows up every possible oil leak that wasnt leaking noticeably before.
Try a 10w40 and see if that cures it. If not then it is probably time to have it looked at :|
I always run the Castrol GTX 5W30 with no down sides.
Always change it at 3000 miles.
Book time to replace lifters is 6.3hrs. so not a cheap job if a shop was to do it!
Martin
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
Thanks brother I have a great Mechanic and is really cheap so I am saved there! As for the front main seal is this a common issue or is it just because of the oil change and the treatment I did? Also I have engine lite on and had it checked.with the tps going in and out is that a big deal to fix since the cheapest tps I found was 80.00. So is there anything else to buy when I get it like a install kit or just the tps? Thanks so much for your time! I really love the Range Rovers and I got this one for my wife and at a steal of a price!
 

·
Registered
Joined
·
1,758 Posts
Maybe also check that oil filter could be plugged. Since engine was dirty the gunk may affect flow thru the filter. It happened to me on an older chev 283 engine years ago. I don't know if the rangie has a suitable bypass if filter plugs. Good luck.
 

·
JACK'S GRANDAD
Joined
·
9,244 Posts
TPS is a 10 minute job. You will need to reset the adaptive values after though, at least I did.

Martin
 

·
Registered
Joined
·
128 Posts
I had the same thing after I bought my 96 HSE. Some of the bits in the old oil got stuck in the oil ways to the left hand rocker shaft and I had to blow them out with air. That said I ended up replacing the rockers and shafts due to ware and it made a big diference to fule and speed :D .

Yes, you will need to have the adaptive values reset after though.

Sid.
 
1 - 7 of 7 Posts
Top