RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
When you press the key fob to unlock, the hevac fan on the passenger side (RHD) whirs into action. When you lock the car the same fan runs for a minute or two before sleeping. However, yesterday I locked the car as usual, but 2 hours later the fan was still running.
The immediate thought was a Final Stage Resistor failure, however with the resistor unplugged the fan still runs !
I understand there was a wiring loom problem but thought this issue only affected up to 2005 afterwhich JLR sorted the issue with a revised loom.
Any thoughts would be helpful.
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
2006 is the model year where Ford was being lazy and many things still carried over from BMW. Yet Ford bodged much of the wiring and systems to begin to include parts from their suppliers. This included 4.4L AJ and the 4.2L SC AJ. If the HVAC carried over, the 2003 -2005 RAVE schematics may be of help. I;ve never seen an actual 2006 manual. 2007-2010 is available for down load. See the FAQ stickie at the top of this forum for download links. Don;t forget to add your location to your profile and your Rover's info to your signature.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you for your response RRToadHall, which is helpful. I had hoped to find a member who had encountered the problem previously, but as you suggest will just have to look at the previous and post wiring diagrams to determine what they did for this model and where the problem may rest.
 
1 - 3 of 3 Posts
Top