RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
49 Posts
Discussion Starter #1
Hi All,

I have noticed my bonnet open warning does not work if I leave the bonnet open accidentally.

I have replaced the switch and made sure it seats on the bonnet plus did a voltage check to see if there is power but cannot fathom the problem. I have noticed lots of people with discoveries had hood switch/latch issues and replacement fixed the problem.

Everything on the my L322 2006 is working fine, I used my Gap IIDtool to check faults and all ok.

Anyone have any ideas???

Bruce
 

·
Premium Member
Joined
·
1,308 Posts
My 2005 didn’t warn of an open bonnet either. It shares many electronics with the 2006. Maybe normal?


Sent from my iPhone using Tapatalk Pro
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
49 Posts
Discussion Starter #3
Thanks Keralis

I am puzzled if the bonnet hood switch is fine and there is current to the switch why the ECU would not signal the hoods is open at all.

I have rarely left bonnets open but I did the other day and luckily noticed it bouncing on the freeway, it put a bit of a chill up my spine so I want to fix it from a safety perspective.

Anyone please.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
323 Posts
I get a "Bonnet Open" graphic on my display when the bonnet is open.
 

·
Premium Member
Joined
·
1,308 Posts
My 2010 and 2011 do as well. 2004 did not, 2008 didn't find out.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
49 Posts
Discussion Starter #6
Thanks thats my problem I am not getting the bonnet open graphic when the hood is open
 
1 - 6 of 6 Posts
Top