RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have 2 keys for my 2006 RRSC, one of them works fine, the other will start the car but it will not remotely unlock the doors.

The non-working key hadn't been used for a long time prior, which I presume is why it has stopped working the RCL.

I have put a new battery in but that hasn't helped.

Any ideas on what I need to do to get it working again?
 

·
Registered
Joined
·
1,119 Posts
ngb13 said:
I have 2 keys for my 2006 RRSC, one of them works fine, the other will start the car but it will not remotely unlock the doors.

The non-working key hadn't been used for a long time prior, which I presume is why it has stopped working the RCL.

I have put a new battery in but that hasn't helped.

Any ideas on what I need to do to get it working again?
You need to re-program BOTH keys one after the other:

Programming a new Key(s)

Replacing a missing master key is quite expensive from Land Rover, try not to get sucked into the extra cost of "Dealer coding" You can do this yourself in 2 minutes by following the simple process below.

1) Get in and close all doors. Turn ignition on and off quickly and remove the key (all within about 5 seconds).

2) Within 30 seconds of turning the ignition off, while holding down the "unlock" button, press the "lock" button three times. Release the "unlock" button. (You may or may not get the confirmation from the door locks.) Holding the key at your head level provides best results as the key sensor is in the rear window.

3) Repeat for each key within 30 seconds after the last one you initialized (again if you have more).

4) Right after doing the last key, quickly put the key back in the ignition and turn it on/off again to finalize.
 

·
Registered
Joined
·
47 Posts
My battery died recntly and just replaced but the remote locking was not working. I took advice from this thread and tried to re-code both keys. I have managed to re-code one key but I cannot get the second key to code??

I followed the procedure - ie first key in, switch ignition on and off / held unlock / pressed lock 3 times and released unlock/ Next I quickly tried to do the same with the second key but this does not seem to work? I can code both keys but all the time it is only the forst on that I use in the sequence that works?


What am I doing wrong? I have 2 keys to code.

Thanks
 

·
Registered
Joined
·
1,119 Posts
You only need to do this bit for the second key: (within 20 seconds of the FULL procedure for the first key)

***while holding down the "unlock" button, press the "lock" button three times. Release the "unlock" button. (You may or may not get the confirmation from the door locks.) Holding the key at your head level provides best results as the key sensor is in the rear window.

then

***quickly put the key back in the ignition and turn it on/off again to finalize.
 

·
Registered
Joined
·
1 Posts
I have a 2005 with same problem, but the inner light will not come on. I have tried this procedure and the remoote will not work. Somebody says car has gone to transport mode. How can I get the remote to work?
Regards
Houd
 
1 - 6 of 6 Posts
Top