RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have a L322 2007.

Its got folding blade keyfobs and the ignition key is in the dash not in the console.

I know there are a number of instructions posted on how to resync the keyfobs but nothing seems to work.

I recently left the lights on and flattened the battery. Prior to this everything worked perfectly.

I even phoned the main dealer (I have a newer RRS they supplied/service, so they were very helpful)

Despite having 3 methods of resyncing, non of the methods seem to have any effect at all.
I've tried the one in the outside door locks
The one where you press and hold unlock then press lock 3 times
and the one where you put the key into the ignition slot whilst pressing unlock

Nothing works !

The keys will start the car, its just the remote buttons that don't operate.

I've disconnected the battery and left it disconnected for 30 mins to reset the ECU (or is that BCU?). Done this multiple times all to no effect.

Any ideas ?

Thanks
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
So a bit more info might provoke some thoughts ?
Still got the problem. Took vehicle to a local RR specialist who has looked at it and says.......
All the keys are working but its the car failing to grab the keys when reprogram mode is enacted.
Even he's not sure what it is but he thinks it might be the module that receives the signal from the key
He's having a look through his diagrams and having the car back in a few days
Anyone ever had a problem with the receiver in the car (I believe its inside one of the pillars ?)
Thanks
 

·
Registered
Joined
·
321 Posts
I have the same problem, a while back I had a dead battery and checked with a meter to see if I had a voltage drain, after using the meter the key fobs went dead the button in the dash to open the doors don not work, the dome light does not go on either. I have tried countless times all these methods from the prescribed by LR to disconnecting the battery and holding the two cables together. The only button that works on the fob is the tailgate. Very frustrating. BTW I had to get a new battery. The fobs were scanned and found to be operating fine, the car is not recognizing the fob or something...?????
 

·
Registered
Joined
·
13 Posts
I found a document relating to the RRS 2006 - 2009 which shows diagrams of the keys - they are identical to my keys.
The document explains how the CJB inside the car deals with the rolling data codes from the key etc.
At the end of the document it explains how leaving the vehicle running for more than 6 minutes with a non-synced key will automatically sync it?

Has anyone come across this automatic syncing in an L322?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Fixed it !!

So after a lot of trawling and probably more importantly noticing the radio reception had become really bad as well - I took off the panel that covers the rear screen wiper motor.
And there it was !
A broken wire to the RF Receiver (part code XUO000020)
Resoldered wire
Radio reception back to normal
Key re-sync procedure worked first time !!
 

·
Registered
Joined
·
1,758 Posts
What a great report. Many thanks for putting that info on this site
 
1 - 6 of 6 Posts
Top