RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
The little red light on the key fob will often not light up causing the key fob to not function (automatic locks). I just replaced the batteries so that cannot be it. Sometimes it works fine. Any recommendations?

Thanks
 

·
JACK'S GRANDAD
Joined
·
9,235 Posts
I had the same issues when we first got ours a few years ago.
I ended up going to the next size up in battery's. Cured my problem permanently. The next size up is the same voltage etc, just maybe 1-2mm thicker allowing for better contact I guess. I tried to clean the contacts etc etc etc to no avail.

Martin
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Well now that is intresting. I have had the same issue today i'll buy a thicker battery..Thanks

Scotty
 

·
JACK'S GRANDAD
Joined
·
9,235 Posts
Cant remember the number Scotty, but if the stock size is 2015, I think I used a 2025. If that makes sense?
 

·
Registered
Joined
·
931 Posts
leftlanetruckin said:
I had the same issues when we first got ours a few years ago.
I ended up going to the next size up in battery's. Cured my problem permanently. The next size up is the same voltage etc, just maybe 1-2mm thicker allowing for better contact I guess. I tried to clean the contacts etc etc etc to no avail.

Martin
Martin, u sure u didnt have non stock batteries in the remote to start with. :lol: :lol:
 

·
JACK'S GRANDAD
Joined
·
9,235 Posts
John W said:
Martin, u sure u didnt have non stock batteries in the remote to start with. :lol: :lol:
Not unless all the info on this website is incorrect too! :thumb:
 
1 - 7 of 7 Posts
Top