RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all, another Newbie who loves his RR but has little knowledge on it abilities and 'attributes' (i.e. all the noises from under the bonnet that aren't the V8!).

Looking for reassurances more than advice, but would welcome both.

The brake pump does go on an awful lot - I have had the Accumalator replaced and it went from going on every second pressing of the pedal to every 3rd/4th press - the pump stays on for about 5 seconds. Is this a normal operating trait? I have done some looking on this forum and it mentions 4 presses to 10/12 before the pump should go on. Just concerned as I've also read that if the pump fails (where the system loses pressure), the brakes fails and when I have my wife driving :doh: and 2 kiddies in it, just want to make sure I have no underlying issue.

The back light on the HAVEC display is also intermittent - also looked this (great) forum but it only talked about bulb replacement. Some of the display is there, then it all disappears, then only to return 5 minutes later.

Has anyone fitted parking sensors - looking at some on trademe (New Zealanders Ebay!) and wanted to see if anyone has experience of fitting these aftermarket kits.

Thanks for now - when something seriously goes wrong, I just hope the warranty covers it - just hope its not the suspension as that seems excluded for some reason :pray:
 

·
Registered
Joined
·
453 Posts
Ref: the back light on the HAVEC, loose connection, only way would be to replace the bulbs and make sure the contacts are clean when the new ones go in. Also check the wiring to the havec at the same time.

Ref Parking sensors: i fitted a set, bought some cheep ones off ebay which allowed front and back sensors. (i only fitted the back ones.)
The kit came with a drill bit to drill the bumper and all wiring, which comes in where the tow bar wires enter, to connect to reverse and power.
The module i fitted behine the ash tray and the speaker, to give the bleep bleep crash, i stuck above the panel under the steering wheel.
Works 100% and because i did not fit the front sensors i have 4 spare sensors incase any of the rear ones fail. The kit was approx £30-00

Ref: brakes, cannot answer that one, my pump is starting to come on quite frequently, will be replacing the accumalator this week and then bleeding the brakes before i reassess.
I might have to read that long post about brakes i keep seeing, (If i get a spare day or 2)
 

·
Registered
Joined
·
1,758 Posts
Hi G and welcome to this site. While your air suspension is working take the time to read all you can about it on here. Rover renovations has all the spare parts and advice you'll need to fix it. You could even be proactive and change a few parts before they fail just to avoid driving on the bump stops. Also a reset tool to buy if you need to reset the suspension if away from home. The great thing is there are lots of aftermarket options for the p38 which make it easier to repair which it will need. :p I think more than 3-4 presses on the pedal without pump running is a rarity. Ours is maybe 3 with new accumulator. What year is your range. If pump only comes on after using brakes then pump should be operating properly. If it comes on every few minutes on its own then something is going on. Run time of about 5 seconds is similar/shorter then ours [after fill from a longer rest period]
 
1 - 3 of 3 Posts
Top