RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey all, looking to get some insight on the following issues I am facing with my 2019 Range Rover as I have received no help from my local dealer.

-Back up camera lag. When I put the car in drive the back up camera stays on for almost a minute. It is very annoying to drive and have to look at your backup camera with no ability to use the functions on the screen.
-Over revving. Sometimes when I rev my car from a stopped position (red light, stop signs etc.), it revs very hard sounds are deafening and the startup speed is very unsafe. No my foot is not that heavy. I am just worried it could be a deeper engine / transmission issue that may cost me a huge amount later to fix.
-Seat belt gets stuck whenever I enter the car and the seat adjusts automatically. I pretty much have to wait for a minute until I can even wear my seatbelt. Not a huge issue but very annoying when I get in to the car and just drive off.
-Brakes are very stiff.

Anyone else notice the same issues? I never had these problems in the 150k kms I drove my previous 2015 Range Rover.
 

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
522 Posts
Do you have a lag when you initially engage the throttle prior to the rev and launch? There are several posts here and in the L494 forum discussing this issue.
 

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
522 Posts
 

·
Registered
Joined
·
285 Posts
Not that its the same model....but I've noticed every time I had my l322 in for service and got a loaner....all the new models had this delay on throttle....I often found myself mashing the gas and have the delay then the "vrooom" and then accelerate. Always found it odd but chalked it up to a Discovery and Evoque.
 
1 - 5 of 5 Posts
Top