RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
22 Posts
Discussion Starter #1
OK, so here are all my woes in brief. (As posted elsewhere), during a downpour (about 5 weeks ago) my screen died. Subsequently I lost the Sat Nav, and now the radio has completely packed up. Today, the indicators stopped ticking (they work -flash- but don't sound in the cabin). Also, I've noticed that the Parking Sensor is off when I start the car. It works if you press the button but it should be on by default? This is a genuine request for help -how worried should I be? What can I do? I've had the leak sorted, and was planning on replacing the sat nav computer.. but now I really don't know what to do.

Thanks all in advance..

8~
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
22 Posts
Discussion Starter #2
Sorry you must all think I'm a right muppet- it's a straight-six diesel of course, not a V6. Dunno what I was thinking! Anyhoo- bizarrely, the indicators came back on today, the parking sensor works properly and the radio is alive again - but only for 2 minutes at a time. Weird, all what? The optimist in me wants to believe that the drying out I did made a difference.. however the pessimist is waiting for it all to die again.. And I desperately want the radio back full-time. Honestly, I'd be grateful for any pointers /advice.. thanks.
 

·
JACK'S GRANDAD
Joined
·
9,248 Posts
And where does the indicator noise come from? Stereo IIRC..... Kill that and kill any noises it made before its death.
Sort out the stereo, which you know is screwed up, then move onto any remaining issues.

Martin
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
22 Posts
Discussion Starter #4
Hi Martin. Yes that is good advice, "process of elimination" etc. Thank you :) So, I did exactly that but not quite there yet: this is post today from another thread..

"Hi all. "Stupid question" time I'm afraid. I've just bought and installed a Mk4 Sat Nav computer (from e-bay). Does it need the DVD to work? Reason I ask is that the screen is still blank. The radio is working fine now though (although clearly no read out). A DVD wasn't supplied with the unit, but I expected the screen would just grey out the sat nav option, but there's nothing. So it a) needs to DVD to work, b) the unit is faulty or c) my screen is fried too. All the buttons appear to work..Any advice.. please? PS it's a unit out of a BMW (trying to avoid previous water damage)- but all the connectors fit and all the forums say it should work fine. DVD has red light (but flashes as if seeking the ROM) and screen is backlit- not a dead black screen. Thanks all.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
22 Posts
Discussion Starter #5
Hi Martin. Sorry for late reply. All fixed- thank you. Everything is working as it should do.
 

·
JACK'S GRANDAD
Joined
·
9,248 Posts
What did it end up being?
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
22 Posts
Discussion Starter #7
Long story, but in brief: Water ingress killed the Sat Nav computer: bought a MK4 off e-bay. Plugged it in- Screen still dead. Radio worked but cut out every 2 minutes. Thanks to advice given on this forum, I checked the radio controller in the boot and found a broken pin in one of the connectors due to (you guessed it) water ingress. Chap at work kindly put new pin in for me- all working AOK! So in summary- two units failed due to water ingress. I love my Range Rover- but it's a bit poor that LR didn't recall them to fix this fault.. I'm not the only victim by any stretch of the imagination and I've been told that to replace all the amplification and controller units using LR parts would be circa £2.5K. Not really cricket, is it?
 
1 - 7 of 7 Posts
Top