RangeRovers.net Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
Just trying to understand how many other people are continuing to have problems with the InControl TouchPro Duo. I have a 2018 SVR and the lower screen used to go black at least once or twice per week (sometimes more) but after several updates over the last year and half since I picked it up, it happens about once every two or three weeks. At first I wondered if it was hardware but the reduction in occurrences makes me think software . It will just happen randomly while driving and comes back on the next time it's started.

Anyway would just love to know if anyone else gets this with their 2018+ models.

283335
 

·
Registered
2019-2021 Range Rover Sport
Joined
·
191 Posts
I get the same black lower screen.
sometimes also all screens going black a few minutes and I have the latest updates done.
It’s MY20, August delivery.
But i don’t care, it’s part of the brands experience, „below & among“... ;-)
 

·
Registered
Joined
·
82 Posts
Discussion Starter #4
Nope, never. - Blank screens usually point to the Telematics software. What version is yours?
Hmmm thanks for the tip, I'll check it out -- isn't that just for Navigation? I have the latest system software and have been able to download the OTA updates twice already. I've seen pretty significant improvements in initialization and reliability but it will always be sluggish as they used weak processors and it's built overtop of shitty android. But I'm happy with it overall and it's a shame it wasn't like this when I picked it up in mid 2018.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #5
I get the same black lower screen.
sometimes also all screens going black a few minutes and I have the latest updates done.
It’s MY20, August delivery.
But i don’t care, it’s part of the brands experience, „below & among“... ;-)
Thank you for the feedback. At least I know for me it's not a one off, hardware issue. "Below & Among"..... LOL. My wife will love to use that because she teases me about her perfect Audi.

Yeah it doesn't bother me very much and I absolutely love this SVR. Will likely get the next generation version as well. Land Rover has some time to finally get this stuff worked out. ha.
 

·
Registered
Joined
·
85 Posts
Go into "Software update" and look and the information on the screen. First there is the infotainment software section, and below is the telematics.
Black screens are definitely NOT "part and parcel" of driving a Land Rover.
 

·
Registered
2019-2021 Range Rover Sport
Joined
·
191 Posts
here how it looks once the full dashboard is going all black, only the digital speedo was working.
This was at the highway a few weeks ago and it re-booted back after 10 minutes... 😂

This is my third L494 and my second one with the new infotainment, so after around 50.000mls using the new system, I can say it’s OK to live with and sometimes I have 3 faultless days in a line... 👍
283348
 

·
Registered
Joined
·
9 Posts
I had the opposite today driving home: top screen went black (and remained tilted out) while the lower screen flickered. Persisted through 2 key-out-of-car restarts.

Got home, parked in the garage, took stuff out of the trunk. Opened a rear door to get my coat and noticed the screen lit back up.
 

·
Registered
Joined
·
65 Posts
Probably have had this issue occasionally. I"d say one out of 10 drives, something odd happens with the screens. Usually, it's easily cured with a restart. I have a 2020 with 19B.
 

·
Registered
Joined
·
26 Posts
2020 RRS HSE- yes- had this happen last night on the ride home with CarPlay enabled. Also have the issue of the seat heaters not showing up- was told it could be improved with a software update but need to bring it on for service which is a PITA. Love the brand- my second RRS- hate the stupid quirks.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
83 Posts
I had the opposite today driving home: top screen went black (and remained tilted out) while the lower screen flickered. Persisted through 2 key-out-of-car restarts.

Got home, parked in the garage, took stuff out of the trunk. Opened a rear door to get my coat and noticed the screen lit back up.
This just happened to my wife yesterday. I've never seen it happen before and most glitches seem to be fixed after a quick shut down, lock and restart in a few mins.
No issues today though.
 

·
Registered
Joined
·
65 Posts
2020 RRS HSE- yes- had this happen last night on the ride home with CarPlay enabled. Also have the issue of the seat heaters not showing up- was told it could be improved with a software update but need to bring it on for service which is a PITA. Love the brand- my second RRS- hate the stupid quirks.


Sent from my iPhone using Tapatalk
I remember having the seat heater issue with 19A. Since I updated to 19B i haven't had any issues with that (and the release notes for 19b call out a fix for that issue IIRC)
 
1 - 12 of 12 Posts
Top