Range Rovers Forum banner

Intermittent no start, U0167 fault code

17551 Views 4 Replies 3 Participants Last post by  diff
2008 Range Rover Supercharged

I recently replaced my Steering Angle Sensor due to HDC, DSC, BRAKE, AFS, and Terrain Response fault issues. The upper steering column had to come out on 2 occasions as my first replacement SAS was defective.

A few days after the SAS fix a new issue emerged and has happened about every other day since. Here is what is going on:

- Enter car, everything working ok (steering column and seat adjusts, lighting, screen on with Land Rover logo, etc.)
- Turn key to position 2 and when turning to the start position - nothing. Dead. Electronics die, starter wont turn.
- Most recently today I drove to the store first thing this morning w/o incident. An hour later when exiting store, BAM - turn key to start and dead.

I've tried a few different things such as:
- Taking key out and putting it back in and trying again.
- Waiting for a few moments, then trying again.

Fault codes that I was able to grab:
0x2105 P2105 Evaporative emission system leak heater control - circuit low.
0x500 P0500 Vehicle speed sensor A.
0x606 P0606 Engine control module/powertrain control module processor.
0xC167 U0167 Lost communication with vehicle immobiliser control module.

A few other anomalies:
- An engine fault code came on once. The truck appeared to have gone into a limp mode where it would not go above 1500 RPMs. I pulled codes (see above) then turned truck off thinking it was just an anomaly and restarting would fix. When I tried to restart - Dead.
- "Jumped" with my jump starter on the battery, started right away. The faults I had previously just grabbed were magically cleared like nothing ever happened. I did not clear them.
- On one occasion I started with power pack the starter had to turn for about 3 seconds before it started. Normally its within .5-1 second max.

My temp "fix": Each time that this has happened (about 4-5x now) I pop the hood, hook up my portable jump starter to the battery and voila, starts! The only thing I am doing and the only change is the introduction of my NOCO GB40 1000 amp jump starter at battery. Battery issue?

U0167 seems to represent the issue, but I cannot figure out what is going on here aside from a CAN comm issue. Alternator seems fine when running, starter seems ok too. But why would adding a little extra juice with my jump starter make a difference? The battery is 3 months old

Some additional info, questions for thought:

  • The battery levels out around 12.2 volts at rest. This seems low, but the auto parts store tested 2x and tells me this is normal and they wont swap it. The dealer ran diagnostics on the truck for my steering angle sensor issue (different thread) and they did not see any issue with battery either, just the SAS. Could this be a battery issue after all? I keep reading that Range Rovers are very sensitive to relative low voltage.
  • The truck was at the dealer 2 weeks ago primarily for the airbag recall (Takata). Could that have been botched and trigger this new problem? Interestingly I replaced my SAS after that appointment and the dealer didnt even put the steering wheel air bag back on properly - one of the two springs was not clipped and all wonky.
  • Is the SAS on the same CAN as this VICM?
  • Could I have a loose connection is one of my steering column plugs that had to come on/off a few times with my previous SAS repair?
  • For the P0606 fault, is this on the same CAN as the VICM.
  • Additionally I replaced a rear caliper, rear brake pad wear sensor, front rotors, pads, and wear sensor too last week when I also replaced the faulty SAS but I dont think that has anything to do with my current problems.

Any ideas and suggestions appreciated. I'll continue to update the thread until this is resolved.

Thank you.
See less See more
1 - 1 of 5 Posts
Those are all basically CAN bus errors, probablt caused by the low battery. 12.2V at rest is low probably around 50% charge, should be up in the 12.7V range. Most of these are probably being caused by low voltage, except maybe the EVP leak detector one, which will give you a Check engine light. If your speedometer works and the you don't have ABS, DCS and ABS lights on then the speed sensor one is a momentary thing, not related to a bad wheel speed sensor. What kind of voltage do you have at the battery with the engine running at idle and at about 2000 RPM? Check your cable connections to the battery make sure they are clean and tight
1 - 1 of 5 Posts