RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
2010-2012 Range Rover Sport
Joined
·
32 Posts
Discussion Starter #1
I wanted to share a pretty sweet setup I ended up going with, to compliment the great factory Harmon Kardon speakers and head unit. It was just missing mid and especially low end bass.

Been a while since I had a "setup" installed, probably 15 years+! A lot has changed and now the amps are so small and pack a mean punch! The thump with this setup is crazy, even when up high there is minimal rattling (only on the rear license plate) and outside the truck is pretty well muted with all the insulation in these vehicles. I had a bass knob installed so i can tone it down when i'd like.

I'd highly recommend something like this, it was a night and day difference, cost ran me $1,500.00 for the amp, pre-built sub/enclosure, line output converter, bass knob, wiring and installation as i got a pretty good deal and certainly lesser of a product would have done the job as well but i read really good reviews on the JL Audio equipment.

Let me know if you are thinking of doing something similar or if you have any questions. I also threw in a pic of the original box (last picture of flatter box) I tried which was a sealed W3 12 inch PowerWedge in order to show you how small of a box you can get away with, still with great sound. This one was somewhat close to the smaller and next level up driver but the ported box is a lot louder.

IMG_7263.jpg IMG_8052.JPG IMG_7255.jpg IMG_7265.jpg
 

·
SUPER MODERATOR
2006-2009 Range Rover Sport
Joined
·
4,459 Posts
Re: Installed JL Audio 600/1 amp & 10W6v3 H.O. Wedge sub box

Looks good...completely concur on the poor bass and the sloppy thumping that occurs with the standard gate installed sub woofer. Did you disconnect the speaker in the gate then or remove it completely?

:)
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
32 Posts
Discussion Starter #3
Re: Installed JL Audio 600/1 amp & 10W6v3 H.O. Wedge sub box

Looks good...completely concur on the poor bass and the sloppy thumping that occurs with the standard gate installed sub woofer. Did you disconnect the speaker in the gate then or remove it completely?

:)
Great question I should have included. I thought the same thing to disconnect it but the installers recommended keeping it all intact as they stated the system can get thrown off or malfunction if it detects inconsistencies in how it was originally configured.

I did however turn the bass and mid on the dashboard stereo console controls since i don't need that anymore.
 

·
SUPER MODERATOR
2006-2009 Range Rover Sport
Joined
·
4,459 Posts
Re: Installed JL Audio 600/1 amp & 10W6v3 H.O. Wedge sub box

Excellent...thank you!
 
1 - 4 of 4 Posts
Top