RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Have had a few issues with the InControl Touch Pro software running on my 2020 RRS. Two specific issues I can identify now, a number of others lurking around in my head that I'm sure I will remember later.

1) SiriusXM Station Logos - Somewhere in the past 45 days, the logos for SiriusXM stations have disappeared. The shortcuts I mapped to my home screen now just show white logos. Not sure if this is connected to the cancellation of my AT&T data trial, but it does seem like these two events probably happened within the same narrow window of time. I don't know why you would need a data subscription to fetch SiriusXM logos. Any idea of how to reset the logos in the station list?

2) Android Auto - A ton of random, (un?)related issues here. Have experiences issues where:
a) plugging in my phone and loading AA during the InControl SW startup itself causes the "Source" to set itself to AA but never output sound.
b) I'm streaming music from Amazon Music in AA and AA freezes. Touchscreen does not allow any interaction with AA. I can disconnect my phone, restart it, AA screen stays frozen on touchscreen. Requires a full shutdown of the entire vehicle (open / close door plus 30 seconds of a black touchscreen) before it will work again after turning back on.
c) AA is streaming music (normally from Amazon Music) and the "Source" remains on AA but all audible sound disappears. Cannot hear any sound from AA (despite music still "playing" in the app on my phone and reflecting as such in the display on the touchscreen) unless I follow the reboot cycle outlined in 2b above. Also cannot hear music if I switch source to SiriusXM. Only source which outputs sound is FM / HD Radio.

I'm running latest versions of Android 10 (Galaxy S20 Ultra), Amazon Music and the InControl Touch Pro software.

It's an exhausting inconvenience I would love to solve for, but hands are pretty tied when troubleshooting software.

Any ideas or similar experiences here?
 

·
Registered
2020 RR P525 HSE
Joined
·
7 Posts
Sirius didn’t update, your car missed it. Park your car in a unobstructed area, let it run, log into Sirius and send a new signal. Then wait that will start the new download and then refresh your system.
 
1 - 2 of 2 Posts
Top