RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
261 Posts
Discussion Starter #1
I've had this version on my 2019 HST for just over a week, and it seems to have a serious problem in my vehicle.

The audio output (Media, Phone, Navigation/voice response) is broken. The system visually seems to be working, but it is silent. If I turn the volume knob, the indicator pops up on the screen, but does not move (locked up). If I go into Audio Settings, my choices are all neutral, as if I never set up the bass, treble, stereo/Meridian selection, etc.

The phone physically works, but it is dead silent. Navigation voice is dead.

Just like someone unplugged an amp.

I've found a work-around. I took out my spare tire, and have a nut driver ready to disconnect the battery ground for a few seconds, and then go about my business. This will temporarily allow the car to function until it is parked again, long enough for the car to have shut down. Hopefully, I don't get a flat tire before it is fixed.

What gives? My RRS dealer can't see me until October 14th.
 

·
Registered
Joined
·
7 Posts
Hi there, that happened to me about three months ago. I think the problem drains the battery, I was without audio for a few days and at some point I couldn’t start the car, the dealer had to pick up. They replaced the battery and don’t know if they did the update again.
When I got the car back the next day, it happened again!. I disconnected the battery and once reconnected everything was working fine, I haven’t had any problems ever since.
Talk to your dealer and work out a way for them to take a look at it sooner.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
261 Posts
Discussion Starter #3
Dropped her off at the dealer this morning. Was able to demonstrate the issue. They gave me a Discovery Sport (brand new) off the lot for a loaner. Said they will need to keep it for a few days.

We shall see.
 

·
Registered
Joined
·
261 Posts
Discussion Starter #4
4 Days at the dealer.... They said that the other dealer's service tech did not update correctly to 19A4. Really? Says it is OK now. I had a key fob issue noted in another post, and they decided to replace the receiver. This Discovery loaner isn't any better than a Ford Escape, except the sound works.
 

·
Registered
Joined
·
261 Posts
Discussion Starter #5
Well, the Rocklin service team is a bit more thorough. Replaced the receive, master control modulal in the I.C, but found some problem in the Fob's button, but passive is now good. Hope for next week to pick it up.
 
1 - 5 of 5 Posts
Top