RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
2016-2018 Range Rover Sport
Joined
·
15 Posts
Discussion Starter #1
Hi, this morning when I started my RRS, the InControl display starts...but shortly after it shows a 'Home not available' mesaage and reboots. This happens constantly now.
Yesterday I changed my SIM card to T-Mobile, added a Home 1 and 2 custom panel and enabled WiFi hotspot. All was working well yesterday.

Anyone seen this before or knows how to resolve? Since the home menu is no longer working (can't even swipe right)...I can't even try to delete the new panels I added.
 

·
Premium Member
Joined
·
1,854 Posts
yeah. I had the same thing back when I received the car: added a new home screen & next day the whole thing fell apart. you need a software update. it won't fix itself.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
15 Posts
Discussion Starter #3
Apparently my software is up-to-date. Still they Will take it in and try fix.

Question, for these issues, do Landover compensate customers? Essentially, you aren't getting what you paid for. I feel they should.
 

·
Premium Member
Joined
·
1,854 Posts
You can be loud and the dealer might want to make it good. Land Rover will fulfill the warranty requirements.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
15 Posts
Discussion Starter #5
It took them about two weeks to resolve the issue and eventually they had to replace the computer. I told them that was unacceptable for a new vehicle and would like it replaced...they basically said if it can be fixed, that wouldn't happen. At one point I had to take several days off to go into the dealer because they would not return calls.
In the end, they did fix ...but I am extremely disappointed in the service and response, or lack thereof, from customer service. Thinking of possibly lawyering up on this one...though it's not my thing.
 
1 - 6 of 6 Posts
Top