RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I’ve had plenty of issues with incontrol since I bought it. 1 minute it works then Apple do an iOS update and the next it doesn’t work.

So I write this from the UK and read on if you have issues with an iPhone.

After they did a software update on the car it stopped working in Oct 2017. It wasn’t until Feb 18 they released an update and it fixed it. Then...
iOS updated and it stopped working with my iPhone 8 Plus.
Months went by and they were blaming my phone and battery charger and spent hours trying to resolve it. They’d already blamed my iPhone 7 two months before so I went out and bought the 8 plus.

You only have to read the reviews of the app in the App Store to see many people have issues.

1 minute incontrol opens, the next it won’t, or the apps show but no audio comes through.

JLR suggest resetting network settings on phone... didn’t work.

JLR suggested erase and install on the phone... didn’t work.

So I got onto a really helpful guy at Apple who suggested the Recovery Restore. This is where you hard wire to iTunes on your computer then recover. You’ll need to google it for your model phone.

Plug it in and back up to your computer first!!

For the 8plus, tap Vol Up, Vol Down, Hold Power button until it switches off then follow the instructions to recover, then re install your back up.

Basically it restores your phone to new then puts all your apps back on.

Holy smoke! It fixed it. Plug in, disconnect it from incontrol. Audio plays seemlesslt. The whole thing works perfectly again.

I fed the info back to JLR who thanked me and will be suggesting it to others with this issue.

Their technicians could have saved hours had they suggested this option first but none of them at my dealership or at JLR head office here in the UK knew about that. However they DID know many have problems exactly the same.

Hey, it’s a good thing to do to your phone periodically anyway.

I hope it helps if you are having incontrol issues.
 

·
Registered
Joined
·
3 Posts
+1 on this. The same worked for me. I was using the iOS12 beta and as soon as I upgraded the vehicle wouldn’t work with my phone at all. The iTunes restore back to iOS 11.4 combined with the recently updated (but still crap) InControl app and I haven’t had a single issue using Spotify, music, etc.
 
1 - 2 of 2 Posts
Top