RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everybody!
Needs some good advice regarding a problem I have, with my L322. It is a 2003, 4,4 petrol Vouge.
Bought it after summer, and has been driving approx. 5000 Km, since then.
Has made some services, and also had a lot of electric problems, but nothing big. The car had been standing still for a year, when I bought it, so the calculation that problem could occur was there.
It has been classic problems, such as neutral swith problem, suspension alarms, and high/low motor alarms, e.t.c.
However, those I have managed to solve. ( Or live with )

Now to a more bad thing.....yesteday I was at a local shop, and when I came back to the parked car, I unlocked it with remote, without problem. Put in the key, and turn......it is stucked only a few degreas from stop position.
I can hear a clicking from steering column, when key is inserted, but it is impossible to turn to pos 2.
I tried the Fuse 18 thing, with no sucess. Also disconnected battery, no sucess.
It ended up with a tow truck, who took my dear RR to the garage att home.
Here it now stands, and looks sad.....

I read a lot of forums, and started to check. I have noted that the key can be difficult to turn sometimes before, so I disconnected the keyswitch, and dismounted is totaly. there was a lot of dirt in the mecanism, so it was not a waste of time, but there was no problem in there, and also opened the switch contact. Looks like new.
I took apart the coil, and plunge, that locks the key, and it was no problem there. I also tested the unit, with power on the coil, and it works properly. It only needed 8 Volts to lift, so the coil seems to be in good condition.

So next step is to check the steering column. I am working on take it out from car, so I can open it. My plan is to drill the "lubricate" hole, but I prefer to open it totaly before, so I dont drill into coil.

However, If this not works, it seems like a new steering column is necesary. My current has not had any tilt and telescope function lately, and that problem was also found. The telescope motor came out at the brakepedal, and was hanging in the cables. Yess...the plastic holder was broken.

Now to my question: What more to do ?? If I change to a new steering column, do I need to programe the ECU unit ??

Any suggestions to a Swedish RR owner ???

Best regards
 

·
Registered
Joined
·
346 Posts
Do more searching. There is a write up in a British Magazine several years old that has an easier solution that accomplishes the same thing. I have it at home on my other computer but it will be several days before I can get it. You just have to search the web until you find it. It has pictures of the process.

Some have found that the magnet in the solenoid is cracked and that is the problem. Replacing the magnet and reassembly has solved their issues.

It may be possible that the magazine repair allows removal of the solenoid - so both can be handled at the same time. I just don't recall.
 

·
Registered
Joined
·
346 Posts
I tried finding the write up, but no luck. As I recall the steering column was left in the vehicle but the repair was similar to what the individual in this video did, drilling out the pins, and opening up the box containing the bad solenoid.

https://www.youtube.com/watch?v=mw3U5yR_Ua0

Going this route will allow you to see if the magnet is split.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hello kg74, and thanks for advice. I took the steering column out today, and drilled it up. The magnet was broken.....so now I am searching for a magnet. Tried to produce one, out of one I had, but impossible to drill, or lathe, in a magnet. Searching on the web for the moment.
I attached some photos from today.

steering1.jpg steering6.jpg steering4.jpg steering12.jpg
 

·
Registered
Joined
·
346 Posts
I have the information at home regarding the magnet, but will be gone for a few days. I saved all the info in the event my steering column failed. There are posts out there where people explain what magnet you need. Just keep digging you are very close to a solution.

Your posts are very helpful. I am appreciative you took the time to show the broken magnet. Keep the updates coming.

I will do some searching to see if I can find the information. It is out there. Basically just measure the inside and outside diameter of the magnet and the thickness and start looking to see what is available where you are at in Sweden. From what I read the magnet is not difficult to source.
 
1 - 8 of 8 Posts
Top