RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I know this has been covered multiple times but just wondering if anything new has been discovered. I just bought a 2005 HSE and everything works perfectly except over the weekend the key would not turn to start the vehicle without multiple attempts, (sometimes as much as 15-20 minutes of trying). I did come to realize that once you get it to turn you can leave the key in and it will turn everytime but that's naturally a short term fix. To clarify, the problem is in the steering column's ECU or in the console's actual ignition switch? I have only owned the vehicle for less than a month and love it until now on what I'm reading for the cost of the repair on this! I am hoping there are places to buy either used or repaired parts to keep the cost to a minimum...any help or pointing in the right direction would be greatly appreciated.
Thanks, Greg.
 

·
Administrator
Joined
·
27,820 Posts
Since the 2005 Sport was not sold to the NAS market I have a feeling you are in the wrong forum. If you pop over to the L322/MarkIII section you will find several threads on this topic as well as a couple active on the first page.
 

·
Banned
1995-2002 Range Rover P38A
Joined
·
3,952 Posts
I also suspect he's in the wrong forum but out of interest, when did you get the Sport over there? I imported a 2008 4.4 HSE sport from the US a couple of years ago. Even that was an oddball as although an early 2008 in the States, it was a very early 2007 model over here as by mid 2007 it had been dropped and replaced with the 4.2 Supercharged motor.
 
1 - 5 of 5 Posts
Top