RangeRovers.net Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
After pulling a trailer yesterday, I noticed whenever I turned the car on, it would rev high for a few seconds as if I was giving it gas immediately after starting it and then it goes back right to normal immediately after
 

·
Registered
Joined
·
238 Posts
Re: I start the car and it revs real high and then all is normal

Could be because of a drop in temperature, the cold air sensor tells the car it needs more of a boost to get going, or it could be first signs of your IAC (idle air controller) going.
On the old RRC you could take out from the intake plenum and try cleaning it with some carb cleaner, or replace it with a chevy astro van one, but not sure about the p38.
 

·
Registered
Joined
·
123 Posts
Re: I start the car and it revs real high and then all is normal

Had this last week ....Was the throttle position sensor ...readings all over the place ..Thank you rovercom..... :clap: :clap: Put my old 100000 mile'r TPS back in reset adaptive values back to normal.............................The duff one was only 15000 mile's old......mind the engine temp sensor went that week as well.....
 

·
Premium Member
2002-2005 Range Rover MkIII / L322
Joined
·
3,622 Posts
Re: I start the car and it revs real high and then all is normal

I wouldn't lose any sleep over it.

Enjoy the quirks of LR ownership.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
258 Posts
Re: I start the car and it revs real high and then all is normal

Where is the IAC located
 

·
Premium Member
2002-2005 Range Rover MkIII / L322
Joined
·
3,622 Posts
Re: I start the car and it revs real high and then all is normal

In between Rave and search.
 

·
Premium Member
Joined
·
1,855 Posts
Re: I start the car and it revs real high and then all is normal

Edable said:
Where is the IAC located
It has a rubber hose on each side, one connected before and one connected after, the throttle butterfly. I.e. it controls the amount of air bypassing the throttle butterfly.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
258 Posts
Re: I start the car and it revs real high and then all is normal

Hey Mag,

Just hope u r no school teacher.U'll give too much home work. :D

Paul,

Thanks
 

·
Premium Member
2002-2005 Range Rover MkIII / L322
Joined
·
3,622 Posts
Re: I start the car and it revs real high and then all is normal

Edable said:
Hey Mag,

Just hope u r no school teacher.U'll give too much home work. :D

Paul,

Thanks
It's the old "teach a man to fish" deal.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #12
Re: I start the car and it revs real high and then all is normal

how do I know the IAC is going? For the past 2 months ive had that issues when I start it and it revs high, now all of a sudden, after changing my water pump, (not the first time but the 2nd) I restarted the car and it barely started and as soon as i gave it gas (in park) it cuts out. I re-started 2 more times after and the 3 rd time, it didn't even want to start, then i re-started again. I know it has nothing to do with the water pump. Right after I changed the water pump, the car started right up after 5 days sitting NO PROBLEM. Then I turn it off, go get more coolant and turned it back on after 30min and then I all of a sudden have this weird issue. I start the car which is barely starts and then it cuts out whenever I give it throttle. when I say barely starts, it doesn't struggle to start, it starts but feels weird, like its running real quiet and doesn't seem like its powerful, i haven't driven the car yet until i pull the code tomorrow to see whats up with it. Could this be my IAC or MAF? it idles fine but just feels like its down on power.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #13
Re: I start the car and it revs real high and then all is normal

turns out its nothing, its reading P0116(engine coolant temp sensor) which is the coolant im flushing since i just did the water pump, any opinions?
 
1 - 13 of 13 Posts
Top