RangeRovers.net Forum banner

161 - 173 of 173 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #161
You up and running yet?
i mean ive been driving the car for all this time, done about 500-600 miles. but the lean codes and fuel trims still there.

tomorrow it goes for gearbox flush, am going to ask they update the pcm as well, hoping its that cause am outta ideas.

the only real negative effect this has been having is my mpg is like 10.
 

·
Registered
Joined
·
151 Posts
The fuel trims are they just high at idle? And have you checked the hose to the fuel pressure sensor hasn’t blown off the charger mine keeps doing that
 

·
Registered
Joined
·
151 Posts
Here you go - I put a jubilee clip around it and then a bolt to hold the clip as it was making me mad it kept coming off - also wha it’s your maf date stamped?
283283
 

·
Registered
Joined
·
119 Posts
Discussion Starter #167
i replaced the maf, with a £30 quid one tbf but i doubt its what since theres no change between either maf. its with the workshop now anyways, if they manage to fix it with the pcm update then winning
 

·
Registered
Joined
·
456 Posts
i replaced the maf, with a £30 quid one tbf but i doubt its what since theres no change between either maf. its with the workshop now anyways, if they manage to fix it with the pcm update then winning
Cheap after market maf sensors mostly leans the fuel mix. We tried Chinese homemade mafs, they are working but results are interesting. On wot always failed on idle mostly leans
Crap
You can try from toyota higlander, harrier or lexus rx mafs
 

·
Registered
Joined
·
119 Posts
Discussion Starter #171
Got car back, updated pcm and so far no errors. But adaptations been reset so it could still be broken just waiting on ltft to catch up cause they are on like -0.8
 

·
Registered
Joined
·
119 Posts
Discussion Starter #172 (Edited)
So after driving the car a bit I got a:

P0137: 02 Sensor circuit low voltage

But that went away after a restart.

Now I have
P0172: System too rich bank 1
P0175: System too rich bank 2

Thats because of the lpg which is fine because it always ran a bit rich.

But no fuel trims or lean codes so hopefully that means the PCM update has fixed the issue? Now I can calibrate the BRC LPG and fix the lpg leak I have :p

Oh also my service was

£822

That includes gearbox flush and filter change, differential oil change and the PCM update. The PCM update was like 55quid bit steep but hey ho.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #173
So now lean codes are back, but they only seem to be at high rpm/speed. So am guessing its fuel pump. Ill confirm that when lpg is fixed. LPG won't take any lpg in so am guessing its valve is dead.
 
161 - 173 of 173 Posts
Top