RangeRovers.net Forum banner

81 - 88 of 88 Posts

·
LEGACY VENDOR
Joined
·
801 Posts
Always! :thumb: :lol: Thanks Paul!
The LED switchback feature is really nice; it has a 1.5 second 'soft-on' reverse dimming feature. I like this look better than the regular HALOs, which I think has now officially jumped the shark (now that I don't have it anymore LOLOL)

Couple more close ups:

IMG_0710.jpg
IMG_0711.jpg
 

·
Registered
Joined
·
197 Posts
One thing is for sure, you love Halo lights.
 

·
LEGACY VENDOR
Joined
·
801 Posts
Mannnn, that's looks sweet! You mind posting a link to the LED STRIPS you got?

& I sure wish I'd known about the bleach trick instead of painting my chrome to black!..

All LED components were sourced @ theretrofitsource.com - they're all Morimoto. The problem is - and I didn't know it when I bought them all - they have V1, V2, and V3 iterations of these components. As a result, the color is off between them by a bit. I would have liked them all to be a dead match, but the main (largest) LED is a replacement for a Subaru WRX, and was made long enough ago that the LEDs are more cool. If they update all components to version 3, the color will match across them all.

There are three components per headlight: a 100mm HALO; WRX LED and a 6" flexible strip.
 

·
LEGACY VENDOR
Joined
·
801 Posts
I soaked them overnight, but you just keep watching them, and wait until every bit of the brightness is completely gone.

The plastic underneath is black, glass smooth and glossy.
 

·
Registered
Joined
·
1 Posts
I just did mine tonight, it seems somehow I messed up with the Adaptive front light system, I've got a flashing "light bulb" icon flashing and the AFS system does not work.

Any one has any clue what may cause it? Thanks a lot....
 
81 - 88 of 88 Posts
Top