RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
is it ok to replace the headlights and the foglights bulbs with a higher wattage? oem is 60/55W, thinking of putting 100/90W or 80/70W. any comment, suggestions, and advise would be realy much apprciate it.

Thank you,
'01 4.6HSE - MR ROV3R
 

·
Registered
Joined
·
72 Posts
I've been impressed with these:

http://www.sylvania.com/ConsumerProduct ... oductLine/

I think they're about the same wattage as typical halogen, but more efficient.

Between the BeCM horror stories and the 10 year old wiring harness, I'm hesitant to move away from the OEM specs by much.

60W is ~5 Amps, 100W is ~8A - nearly double the current is probably the about the design limit of the harness when new.
 

·
Registered
Joined
·
442 Posts
Selby P38 said:
G'day mate,
I just replaced out my low and high beam with Phillips Extreme, very happy with the result ,havn't done the fog lamps yet but check out this post
As per the previous post you will read that going to 100watt may lead and has burnt out wiring looms :naughty:
The reveiw topic below will gives a good detail of what to buy and links to buy online if your local parts shop don;t stock
Regards Graeme.

viewtopic.php?f=3&t=19872&p=170062&hilit=phillips+extreme#p170062
 

·
Registered
Joined
·
276 Posts
I upgraded to Osram Night Breaker bulbs (both H4 low and H1 main beams, these have 55/60 watt as legally required, but are really much brighter), I wrote about my experience in the thread mentioned by Graeme, last post of the thread.

No bulb has failed yet.

Sigi
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
1st of all, thank you all so much for the inputs :thumb:
I will be putting a high heat resistant harness with ceramic plugs for high wattage bulbs, hopefully this would solve the burn/melt down harness problem.
I'm more concern if BeCM would get affected by changing high wattage bulbs. Has anyone replaced their bulbs with a higher wattage? :think:
 

·
SUPER MODERATOR
Joined
·
27,725 Posts
My rigs previous owner ran 100/90 or 100/80 for a several years. The offroad and fogs had 100s as well. I kept them for a couple years and never had any issues even with all lights on at once. I recently changed over to Sylvania XtraVisions for main, dip and fog due.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,334 Posts
I haven't uprated the headlight bulbs but I have fitted the large Safari 5000 spot lights (STC8481) to my p38 and I used the proper wiring loom (STC8884). This takes the power straight from the battery via a relay which I think from memory was rated at about 35 amps. While I was at it I uprated the in line fuse and fitted 100 watt bulbs.

Spotlights only come on with main beam. There is no additional load on the original vehicle wiring.
Been running it for about a year with no problems.

Thinking about uprating again to 120 watt bulbs which would pull around 20 amps.

dave
:)
 
1 - 10 of 10 Posts
Top