RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter #1
I have fitted a new radiator and electric fan to my dads 2002 diesel today, blead the cooling system and it was idlig fine.
When he got home the idle while in drive has gone up to 2500rpm but is ok in park. I have checked everything out and cant find a reason for it. Has anyone come accross this before or can you give me somewhere to start looking.
Thanks
Mark
 

·
Registered
Joined
·
89 Posts
Hi is it possible its got an air lock and thinks its on a cold start when i change radiator fluids on any car i fast idle it for about ten mins with heater on full and cap off expansion bottle until it is blowing hot air and temp needle is sitting normal.to what it had been previous.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #3
You may be right, my dad brought the car back over to me (about 5 miles) and as he got to the bottom of the road it cleared. I took it a drive round sitting in traffic and on a dual carriage way and it has behaved itself. He has just phoned as he has got home and its now running ok, so i think (and hope) that you are right and it was an air lock.
Thanks for the quick reply.
Just in case anyone else was thinking about a kenlow fan it has transformed the car,it is more responsive and very quiet, a worth while upgrade.
Mark
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
977 Posts
pegasus said:
You may be right, my dad brought the car back over to me (about 5 miles) and as he got to the bottom of the road it cleared. I took it a drive round sitting in traffic and on a dual carriage way and it has behaved itself. He has just phoned as he has got home and its now running ok, so i think (and hope) that you are right and it was an air lock.
Thanks for the quick reply.
Just in case anyone else was thinking about a kenlow fan it has transformed the car,it is more responsive and very quiet, a worth while upgrade.
Mark
Hi,
Hw did u connect the Kenlowe to the system?

regds

kapila
 

·
Registered
Joined
·
217 Posts
Hi,

I just dropped a bomb and go away.... Pictures of that mod... please :mrgreen:

Do you used the switch from the kenlowe kit? or put another one?
 
1 - 6 of 6 Posts
Top