RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
112 Posts
Discussion Starter #1
Picked up a 2015.5 MY RRS last night. 5.0L SC with Dynamic, 21,000 miles and has CPO till 2021. LOVE IT! :)

Few things that i noticed after a few hours driving:

1. On restarts, both cold and sometimes warm, idle sits at about 1,500 RPM for about 30 seconds. I understand when it's cold, but why when it's upto temp as well? Has this happened to anyone?

2. There is a slight knock/clunk in the front end when slowly rolling over potholes. I have heard about this on these trucks. Is there anything specific i should look at? Googling i came up with sway bar bushings. What exactly am i looking for? Mine look fine to me... Do i need to remove them to inspect them? Or maybe replace them with something better?

Thanks in advance fellas!
 

·
Premium Member
Joined
·
1,828 Posts
Re: High idle at Start-up and famous front end clunk

1. normal.
2. show it to the dealer. if it's a real problem, why spend brain cells and time - that's what warranty is for.
 

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
112 Posts
Discussion Starter #3
Re: High idle at Start-up and famous front end clunk

1. normal.
2. show it to the dealer. if it's a real problem, why spend brain cells and time - that's what warranty is for.
Glad to hear the idle thing is normal for these trucks. Definitely a first for me (and doesnt feel right), but if others have the same thing, i'll just live with it.
 

·
Registered
2013-2015 Range Rover MkIV / L405
Joined
·
112 Posts
Discussion Starter #5
Good stuff. And ill take it to the dealer for the front end clunk in about a week or so. I hope it’s the sway bar bushings and not the shock/strut because i dont think that struts are a covered item under warranty.
 
1 - 5 of 5 Posts
Top