RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1 (Edited)
Hi, my 07 rrs hse from one day to another has brake problems, if i press brake it works like around 70 percent of when fully working

But if i press brake a second time really fast after first breaking, then almost no brakes at all (pedal don't sink to floor. doesn't go down too far!), It's very hard

Also almost no brakes on reverse

Brake pads less than a year old

Help appreciated

Thank you
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
841 Posts
My first guess would be the Master Cylinder.
Also better have a look at the fluid level. You may have sprung a leak in one of the brake lines. I had to replace the rear two of mine last year. Rusted out.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #3
Brake fluid level is full
Later gonna have to put it in off road and look at each brake line for leaks
 

·
Registered
2006 Range Rover Sport 2016 Mercedes S550 4MATIC
Joined
·
123 Posts
Take some pictures of the brake fluid level for comparison later. If there's a leak, the level will come down sooner or later.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
Take some pictures of the brake fluid level for comparison later. If there's a leak, the level will come down sooner or later.
thanks,
Its been with the brake problem for more than a week, and i use the car everyday
I dont think fluid its leaking
 

·
Registered
Joined
·
115 Posts
Discussion Starter #8
No leaking in any of the 4 brake hoses, and fluid level stays the same
Master cylinder might be bad

Any other component apart from master cylinder can make brakes behave like that ?
 

·
Registered
Joined
·
115 Posts
Discussion Starter #9
I think my brake booster has problems, if i start engine for 3 minutes, press brake, turn off engine then pedal goes back up to resting position

Are break boosters known to go bad on these cars ?
Thanks
 

·
Registered
Joined
·
115 Posts
Discussion Starter #10 (Edited)
Did my research, and everything point to a bad brake booster
Brakes work almost perfect only once because of vacuum pump, but pump alone can't handle breaking 2 or 3 times really fast

brake pedal really hard if press second/third time really fast after first pressing because no vacuum to make pedal softer

If wait about ten seconds after pressing brake, then pedal feels normal and breaks almost perfect again

I drive a little aggressive, so now keep a little more distance than usual with car in front

My friends always tell me i think im driving a ferrari😋
 
1 - 10 of 10 Posts
Top