RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
148 Posts
Discussion Starter #1
Bit of a strange problem... Book symbol is on. I can hear the compressor kick in and the fan work on all speeds but very little air coming out of the vents if left for awhile the external temp on the display starts to drop even though it's 30+ degrees celcius outside. Weird. So any ideas? I have a 96 HSE if that makes a difference.
 

·
Registered
Joined
·
26 Posts
It sounds like one or more of the blend motors have failed, or it could be as simple as a faulty relay.The blend motors determine where the air comes from (aircon, heater or outside) and where the air goes (fascia vents, footwell vents, demister vents).

Try swapping the relay out for a known good one. If its the motors then they need to be replaced (not a nice job).
 

·
Registered
Joined
·
553 Posts
If the compressor is engaging the GAS is fine, my idea is the external temp sensor is broken.Try replacing it and see it if makes a difference
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
148 Posts
Discussion Starter #4
On further thinking, simply being that 1 The fans definately make the right noises for the different speeds and 2 the vent positions are all working (head, screen, feet, mixed) I've narrowed it down to perhaps being the Recirculation air flap motor being stuck and somehow blasting the air back out the intake cooling the external temp sensor, because with the fan off the tempo sensor works as per normal. Does this sound feasible? Other than the air being blown out through the air intake.... That's a bit of a stretch but it's the only explaination I can think of that accounts for the temp dop.... Weird.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
148 Posts
Discussion Starter #5
Fixed it/ found the problem. It's just a faulty relay... Thankfully.. :dance:
 

·
Registered
Joined
·
24 Posts
Shadow Keeper

I have the identical problem with my 97 HSE here in Brissy.

Just to sound like a clutz, which relay exactly did you replace??
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
148 Posts
Discussion Starter #7
The two relays for the fan motors in the fuse/relay box under the bonnet. Standing at the side of the car looking at the box they are at the bottom right of the box, just check out the picture under the lid. Only one of mine was knackered, but I replced both, the air con works SO much better now.
 

·
Registered
Joined
·
24 Posts
Shadow Keeper

BINGO!!!!!


You dont know how long this thing has bugged me with the fault code showing a blend motor problem instead of the relay.


Thanks heaps
 
1 - 9 of 9 Posts
Top