Range Rovers Forum banner
21 - 27 of 27 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #22 ·
There's a company in Van Nuyes , CA that sells rebuilt ones its the pixels. They look as like new even the graphics are redone
$99.00 bucks 1 year warranty. Worked great for me. Google it
Hi, thanks for your post, I will have a look at that. But in fairness, our man Marty is in the UK and has a very good reputation for fixing the HEVAC display.

I am just waiting for a set of HEVAC replacement bulbs to arrive in the post, and I will try the other suggestions next week when I get the new bulbs. There seems to be a possibility that an earth could be loose under the display, and an older post also advises checking an earth connection behind the drivers side footwell panel [RHD vehicles].

And Marty suggests checking a cable that goes into the black plug, connected into the right hand side of the back of the HEVAC unit. Apparently, this is connected to the dashboard dimming switch and could be a problem.

Pierre3.
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #23 ·
Hi, a general question about the HEVAC display - is it lit by the green, 2 watt bulb all the time ? I suppose that it must be otherwise you wouldn't be able to read the display during the day. I would just like to confirm that the 2 watt light is on all the time.

Pierre3.
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
4,229 Posts
Yes, it is the green 2 watt lamp that lights the display, and is on whenever the HEVAC is on.

The pixel fix I offer is also one of the rubbery zebra strips. I don't know how price compares to the french ones. I know a couple of LR places in France that have bought some from me before in batches of 10 at a time! Must still be a few P38's running around over there!
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,317 Posts
Hi Pierre,
What was the solution, finally?
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
491 Posts
I did the zebra fix but one time my display did not light up I pushed all the connectors and wires nice and firm and my screen was back.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,317 Posts
Thanks. My blower motor not working and just after I removed it the HEVAC screen went blank. Found that instrument cluster connector had come loose and when pushed it back everything was back.
 
21 - 27 of 27 Posts
Top