RangeRovers.net Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
962 Posts
Discussion Starter #1
So, my Hevac display started to go bad, missing couple of those lines that make up the numbers.

I know the fix has been discussed here before in the forum (something to do w/ a silicone strip that presses the wires against the connection), so I searched, but can't seem to find the proper link.

Can anybody out there help me find the link? Thanks.
 

·
Registered
Joined
·
962 Posts
Discussion Starter #3
Yeah, I did look through the main page, The Problem & FIxes page, but only repair procedure that I could find are related to the light bulb fixes for the LCD backlight and the buttons-Not the ones related to the LCD display itself. Of course, I may have missed it, but I don't think it's there.

I do recall somebody posting pictures and instructions in the forum itself, probably sometime last year. I've searched for them, but can't seem to find them now.
 

·
JACK'S GRANDAD
Joined
·
9,244 Posts

·
Administrator
Joined
·
27,818 Posts
TheoR said:
Yeah, I did look through the main page, The Problem & FIxes page, but only repair procedure that I could find are related to the light bulb fixes for the LCD backlight and the buttons-Not the ones related to the LCD display itself. Of course, I may have missed it, but I don't think it's there.

I do recall somebody posting pictures and instructions in the forum itself, probably sometime last year. I've searched for them, but can't seem to find them now.
Apologies I thought it had been copied to the home page. I'll do a bit of searching when I get home as I too remember the pics.
 

·
Registered
Joined
·
962 Posts
Discussion Starter #7
Thanks ghur for finding that writeup! That's exactly the post that I was looking for.

I hope this gets posted in the mainpage, as it's well written, and since almost all P38 owners I know have this problem.
 

·
JACK'S GRANDAD
Joined
·
9,244 Posts
And when I try to click on the links posted in here, one by myself even, it only goes to the main forum page and not the thread....
Attempted to click on one in the search results and got the same thing, but figured it was a one off. The tried to click both these links, same result.

Martin
 

·
Premium Member
1995-2002 Range Rover P38A
Joined
·
1,115 Posts
And when I try to click on the links posted in here, one by myself even, it only goes to the main forum page and not the thread....
Attempted to click on one in the search results and got the same thing, but figured it was a one off. The tried to click both these links, same result.

Martin
Hey Martin, Check my post in the General Discussion section. I'd put the link here, but it won't work for either of us. Sorry to say, but I feel better now that I'm not the only one with this problem.
 

·
JACK'S GRANDAD
Joined
·
9,244 Posts
Hey Martin, Check my post in the General Discussion section. I'd put the link here, but it won't work for either of us. Sorry to say, but I feel better now that I'm not the only one with this problem.
I checked the settings etc that Carl and Umberto suggested, but that doesnt address the issue of a bad link. Or what appears to be a bad link anyways.
I guess the term "Use the search" is dwindling into oblivion on RR.Net these days. I certainly do not envy Carl etc, having to put up with all this BS.......

Martin
 

·
Administrator
Joined
·
27,818 Posts
"Use the search" is exactly what everyone should be doing. The new owners are showing little interest in fixing any of the issues with the "upgrade". However the information is still easily available. Use the advanced search feature as all of the posts are still there, you just don't have them handed to you as easily as before. As far as envy... I have pretty much given up on the new owners caring about anything outr site used to represent. Umberto and I are doing all the foot work with little if any assitance form the new owners. Other members of the mod team have simply disappeared or don't bother to offer any assistance. Needless to say the old family feel of RRnet has come to a quick and disastrous end for the favour of advertising and lack of care for existing knowledge base or experience.
 

·
Registered
Joined
·
74 Posts
Rest assured gents, as a relatively new member of the Range Rover family, I believe this to be the most comprehensive forum with the best member participation rates. There are plenty of forums out there and when I first obtained my Rover in September, I sought out and searched them all. I've even posted in 4 or more at a time...and the one thing I've decided, is this forum has more participants and participants with greater knowledge...not just opinions (well, maybe opinions too), but definitely with more "usable and educated" knowledge. So, just as I did when I purchased my first Mercedes, BMW, Jaguar and Ford Diesel, I searched out many forums to sample before deciding which were the most useful, amicable and had the least # of (excuse me) idiots who rant and rave.

Therefore, I've settled in and pretty much just made this forum my home for my Range Rover information and participation. If my laptop is up and running, there is a good chance Safari is open to this forum.

Keep up the great work (Carl et al), your work and participation is at the very least, greatly appreciated by yours truly. :clap:
 

·
Registered
Joined
·
29 Posts
<snip> Therefore, I've settled in and pretty much just made this forum my home for my Range Rover information and participation. If my laptop is up and running, there is a good chance Safari is open to this forum.

Keep up the great work (Carl et al), your work and participation is at the very least, greatly appreciated by yours truly. :clap:
</snip>

I heartily second this! Tremendous knowledge base here, and the site admins do a super job. Thanks Guys!.

Have also found using domain name search on google -- rangerovers.net search terms in google search box-- pulls in results forum search seems to miss. Have no idea why; forum search seems to be powered by google so it would seem like the same thing. Maybe something to do with how full google search prioritizes results?
 

·
Administrator
Joined
·
27,818 Posts
The "google" search box above is pretty much useless. Advanced search has two options... single and multiple content. THe advanced single content search is actually much more usefull than a google domain search. We've tried to get the new owners to provide the advanced single search as default but thus far they don;t even respond to requests let alone act on anything.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
38 Posts
As a relatively new member to the forum, but definitely not new to Range Rovers or British cars in general, I have to say that I love this forum. I'm on here at least 20+ times a day keeping up to date on problems that I expect to come my way in the near future. I've searched the forum from what seems like one end to the other to try and solve current and past problems. I will say that I think some new people don't use the search function whether it be by sure laziness, in which they just want the specific answers catered to them, or they simply do not know the terminology or part names to successfully use the search as it relates to their problem. I wish I was better able to offer my assistance and whenever possible, I do. Most of the issues that I have run into are the basic EAS, heater O-rings, pollen filter leaks, etc. Simple things like that have a million posts explaining more than I ever could, but if I can chime in with some quick advice, I certainly will. I definitely have no advice to give as far as rebuilding engines, transmissions, tracing electrical problems, etc. I think there is a large variety of people here from different fields like finance (myself) to Land Rover certified mechanics. I can help you with your taxes, but get your intake manifold gasket replacement advice elsewhere!!

I think people like RRToadHall, Scotty, Dennis, Wreckrunner, Leftlanetruckin, Getlost4x4 all deserve many thanks for their current and past posts and their strong contributions to the site and their devotion to the brand. Obviously everyone deserves thanks, but these are just a few consistent contributors I've noticed.

On a sour note, I am discouraged to find that a couple of my previous questions have gone by without replies. After searching and searching, I came to accept the fact that I couldn't find any similar problems to the ones I was having so decided to start a new thread. I'm not saying they're not out there, I just couldn't find them. 100+ views and not a single reply had me thinking either I've annoyed everyone, my questions are too elementary, or my posts are so **** long that nobody wants to finish reading them! (I try to be pretty specific). Meanwhile, posts on whether to add "angel eyes" or not get everyone's attention.

All in all, thanks again to everyone. As I become more mechanically inclined, I look forward to offering some useful advice to the newcomers.
 

·
JACK'S GRANDAD
Joined
·
9,244 Posts
On a sour note, I am discouraged to find that a couple of my previous questions have gone by without replies. After searching and searching, I came to accept the fact that I couldn't find any similar problems to the ones I was having so decided to start a new thread. I'm not saying they're not out there, I just couldn't find them. 100+ views and not a single reply had me thinking either I've annoyed everyone, my questions are too elementary, or my posts are so **** long that nobody wants to finish reading them! (I try to be pretty specific). Meanwhile, posts on whether to add "angel eyes" or not get everyone's attention.
But look at the posts in that "angel eye" thread and think about whether you would want those kind of comments aimed at you....:lol:
I will however look for these threads you speak of before heading out the door in a few minutes. Sometimes my schedule, as well as Scotty's, can keep us off here for a few days at a time though, so please be patient!

Martin
 

·
Registered
Joined
·
118 Posts
I have to say, this site is what has kept me in my Rover and not running back to the VW's and BMW's I came from. Couldn't do it without this site and you guys. Thanks a million!!!!!!!!!!!
 
D

·
Guest
Joined
·
0 Posts
(On those 'sour notes' what dates did you make the postings ?....)

Fair comments, BonesXJR: I expect that many/most newcomers just don’t read this (early enough):

http://www.rangerovers.net/forum/15-forum-guidelines/15235-forum-tips-pointers.html

- which indicates the Forum site is primarily an adjunct to the main site:

http://www.rangerovers.net/fixindex.html

[As a relative newbie myself I did not realise that at first either…
and I can even do my own taxes !!]

Similarly:-

http://www.rangerovers.net/maintenance/maintenance.html

.... and downloading/using RAVE of course !


I also wonder how many cars/$$$ were 'saved' thanks to all the shared experience/data on this site... ?
 
1 - 18 of 18 Posts
Top