RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
37 Posts
Discussion Starter #1
Anyone experience a humming/vibrating hesitation at 2000rpm between 50 and 60mph. Almost feels like a bad hub bearing but i lose power up hill and if i floor it i get the eng light to flash and give me a random misfire code. i have alot of spare parts from another motor so i checked the plugs,cleaned them and swapped out the coils on the cylinders from reading the codes from my rsw tool. i keep getting 0308 and 0303 but i cant seem to get 0308 to go away.I also get 02 senor codes of 1171 and 1173 but i have replaced all 4 02 sensors bosch brand. the car has had the driveshaft recall and the transfer case recall at 60k. the truck has 117k and well maintained.the only thing i havent replaced is the cats.I was told that it might need another shaft recall but not sure i want to bring it to the dealer.i called the dealer that the previous owner brought it to but would only tell me to bring it in and im not doing that it would be like vultures looking at a half dead Caracas.
not sure what to check next and winter is coming and don't want to get stuck.
any input would be helpful thanks everyone
 

·
Registered
Joined
·
385 Posts
Do any of the codes give a specific cylinder error? I’m thinking it may be a faulty ignition coil.

A bad ignition coil gives similar driving conditions as you describe. I know, because I had a bad coil in the 2004 HSE.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
37 Posts
Discussion Starter #3
i get random misfire codes showing the cylinders but i swap coils and the symptom keeps coming back.i keep getting po308 which is cylinder 8 unless all my old coils are bad which is unlikely.
 
1 - 3 of 3 Posts
Top