Range Rovers Forum banner

HELP LOST ALL POWER AND WONT DRIVE

12596 Views 21 Replies 5 Participants Last post by  privileged6
MY 2003 RANGE ROVER 104K LOST ALL PEDAL POWER WHILE DRIVING ON A QUATER TANK, I PUSH THE PEDAL DOWN AND IT CAUGHT POWER REALLLY LATE THEN WHEN I PUSHED THE PEDAL DOWN AGAIN THERE WAS NO POWER. THE CAR SHUT OFF.. WHEN I STARTED THE CAR AGAIN IT MADE A NOISE LIKE IF A PERSON WAS TO TRYING THE START A CAR BUT THE CAR WAS ALREADY ON. AND STAYED ON ON FOR A COUPLE ME MINUTES THEN SHUTS OFF. I CAN'T PUT THE CAR IN ANY GEARS. IM GUESSING BUT HOPEING ITS NOT THE TRANSMISSION GOING OUT, SOME PEOPLE WERE GUESSING THAT A FUEL ISSUE WAS PRESENT AND THAT THE CAR WASN'T GETTING PROPER FUEL TO RUN BUT I HAVE NO IDEA AT ALL WHAT IT COULD BE. IM VERY CONFUSED ANY HELP WILL BE APPRECIATED THANK YOU ALL FOR READING.
21 - 22 of 22 Posts
Curious how this plays out for you guys... I'm baffled as to why the interior would heat up, unless the engine itself is overheating.

Let us know!
The shop determined the fuel pump was no good, so they replaced it along with the little gasket that goes on top. It took the techs. 2 days to figure out it was the fuel pump! The RR is running fine now and is no longer stalling, nor is heat coming inside from the console area.

Fuel Pump from Cole Europea in Walnut Creek, Ca. was $880.00. I was under the impression my mechanic would get a discount, but I guess not! Gasket was $22.00 and labor a total of $225.00= grand total with taxes $1,350.00 :roll:
21 - 22 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top