RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter #1
2008 range rover hse 150000 miles
replaced bothfrn ir struts, lower contrl arm and bushings and compressor t about 120k.

4 weeks ago i replaced a lower radiator hose and then on the drivre home a suspension fault warning came on...
since then it has displayed a few times and i have noticedon the 4 by 4 screen that the driver front wheel doesn't line up with the other wheels. the red in is off.

using the iland tool, the following codes are read
c1a72-1c front let height senso mechanism
c1a07-62 cross articulation.

the car goes to the bumper stops after a few days sitting.

any thought? what should i do?replace left front height senor?
thank you
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
405 Posts
From underneath the vehicle take a look at both height sensors. The sensors' arms should both "point" outwards. Make sure they do so. Occasionally they get into a mismatch with one pointing inwards - it shouldn't happen but I've seen this several times, usually after previous front suspension component(s) removal and installation.

While you're there, make sure the electrical connector plug with the three wires is securely attached each height sensor.

Rob
 

·
Registered
Joined
·
177 Posts
Discussion Starter #3
thank you for the support.
knowing that the height sensor seems to be malfunctioning sporadically, does it lend to any one issue vs another? malposition vs wiring vs other issue?

this am car is not on bumps.. after 36 hours in the driveway...

also the last time i drove it home, there were no issues and the suspension malfunction warning didnt come up/
thank you
 

·
Registered
Joined
·
177 Posts
Discussion Starter #4
thank you for the support.
knowing that the height sensor seems to be malfunctioning sporadically, does it lend to any one issue vs another? malposition vs wiring vs other issue?

this am car is not on bumps.. after 36 hours in the driveway...

also the last time i drove it home, there were no issues and the suspension malfunction warning didnt come up/
thank you
thank you for the support.
knowing that the height sensor seems to be malfunctioning sporadically, does it lend to any one issue vs another? malposition vs wiring vs other issue?

this am car is not on bumps.. after 36 hours in the driveway...

also the last time i drove it home, there were no issues and the suspension malfunction warning didnt come up/
thank you
thank you for the support.
knowing that the height sensor seems to be malfunctioning sporadically, does it lend to any one issue vs another? malposition vs wiring vs other issue?

this am car is not on bumps.. after 36 hours in the driveway...

also the last time i drove it home, there were no issues and the suspension malfunction warning didnt come up/
thank you
so i took a look at the height sensor and it looks like it points in the correct direction..... I m going to replace the front sensor byt have a few questions
1) should i replace the passenger side as well
2) is there anything i can do with the iland tool to confirm it is the height sensor driver side, and not something else?
 

·
Registered
Joined
·
177 Posts
Discussion Starter #5
so i took a look at the height sensor and it looks like it points in the correct direction..... I m going to replace the front sensor byt have a few questions
1) should i replace the passenger side as well
2) is there anything i can do with the iland tool to confirm it is the height sensor driver side, and not something else?
car has been in driveway for the last two weeks...… and after 24 hrs it ends up on bumper stops.... when istart car, it goes up and down without a problem...…… im going to change the sensor, but any thoughts on this.?
 

·
Registered
Joined
·
177 Posts
Discussion Starter #6
replaced the driver front height sensor... no issues since... thank you all for your support/advice
 
1 - 6 of 6 Posts
Top