RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

I have had all four ride/height sensors changed.. when I select access height the car will drop as normal then its says extended height and raises right up,???
any thoughts anyone.
 

·
Registered
Joined
·
56 Posts
I have had problems with my Rht Rear height sensor for some time. I am not sure if that was the culprit but whenever I start the Rover, it would say ''Raising" and go straight to Off-Road" height. Two days ago I went to an indie shop and they ran their diagnostic tool on my rig. The suspected problem was changed... They also bypassed and re-programmed the Dynamic Response System which is responsible for the computer controlled active anti-roll control (nothing to do with the height sensor). Mine was leaking like a tap and I did not have the funds to repair it right away but I wanted that red-warning light on the display off.
Then they performed a calibration on the height sensors... My rig has been steady and level the last two days. My question, who told you to replace all 4 height sensors? I'm hard-pressed to think why all 4 would go bad at the same time... They could be another issue going on..
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
thanks for the reply,
the car was sitting at an angle and the compressor was playing up so changed the sensors at the same time just for the sake of it.
if they need calibrating then I shall get it booked in.

cheers Nick.
 
1 - 3 of 3 Posts
Top