RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi everyone,
I am a new owner of a 1999 RR SE. So far I love the truck, but there is a problem or problems. There was a lack of air coming out of the vents and no heat or a/c. I did some checking and found that the #7 relay was burnt. I got a new relay and now there is plenty of air coming from the vents and the open book symbol disappeared from the lcd screen. Alas, there is still no heat and no a/c. Doing research, I saw that I might need to replace the fuse box. Anyone know why I am getting no heat and no a/c, but no open book code? Any help would be appreciated. I would rather not go to the dealership.
 

·
Registered
Joined
·
35 Posts
I am just replacing the fuse box on my 99. I let the dealership troubleshoot the problem. Usually they will run all the codes and give you a diagnosis for a few bucks. The all you need to do is fix it yourself after wards.
 

·
Registered
Joined
·
701 Posts
That open book light is soo stupid. My HVAC system has been working fine for a long time and that stupid symbol comes and goes. You might have a couple blend motors that have failed or the climate ecu could be out or on the fritz. Have you tried going from Hi to Lo on the climate control with the fans off and listen for the blend motors? Look to see if the heater core is bypassed and check to see if your compressor clutch engages. Make sure a/c off button is not lit while trying to engage it.
 
1 - 3 of 3 Posts
Top