RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everybody,

my RR2004 doesnt blow any heat out of the foot vents. It works with the two other settings, but having cold feet in winter while driving is not really pleasant.
Any idea what could cause that issue?

Thanks
 

·
Registered
Joined
·
4 Posts
my 04 is having similar issues. I find that if I put the heat up full speed and full hot and cycle the buttons that whatever is sticking (a louver or damper?) gets temporarily unstuck with the heat.
 

·
SUPER MODERATOR
Joined
·
27,684 Posts
it's the distribution motor/doors Remove the motor and see if the flap moves freely
 

·
Registered
Joined
·
967 Posts

·
Registered
Joined
·
215 Posts
Thanks Mark! Does entire dashboard need to come off for the "HVAC box" (sorry, not sure of the proper name) to be serviceable? Or you can pull individual interior trim pieces to get to each distribution motor?
 

·
Registered
Joined
·
967 Posts
You can get to them from the sides, just remove the two console side covers and you should be able to get to them, might have to remove the closure panels under the dash (above the drivers and passengers feet) to get at the ones closest to the firewall but you shouldn't need to remove anything else. Getting the actual dampers out is a different story though. All of the doors are driven by what look like identical stepper motos, but each one is different (2 out the 6 may be the same) and the part numbers end in numbers like 514, 515, 516,and 517. If you need a new one make sure you know which one is bad first. I have most of them here in Shrewsbury, I needed one for the rear console damper and somebody was selling a full set for the price of about one motor so I have some spares.
 
1 - 9 of 9 Posts
Top