RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

The heater and air conditioning on my Range Rover Vogue L322 has stopped working. I don't even get any lights showing on any of the controls for the air con. I've tried changing the 3 fuses (7.5A, 10A & 50A) that are linked to the air con/heater but this has made no difference. Any ideas or suggestions as to what is causing th eproblema nd how I might fix it would be much appreciated.

Thanks.
BigBri
 

·
SUPER MODERATOR
Joined
·
27,784 Posts
Have you pulled the control unit out and made sure it is plugged in and the connection is clean? past that it sounds like the control unit has failed. I don;t think I have ever heard of one completely failing. usually just one or two of the buttons fail.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the suggestion. I did try this but sadly, all connections are good. However, I did then take a look at the fuses again and discovered Fuse 12 (10A) HeVAC Control Unit which I'd replaced yesterday had since blown. I tried fitting a new fuse twice but each time, as I inserted the new fuse, it visibly sparked and blew. The ignition was turned off at the time. I guess this means I have a short circuit somewhere or something worse? On the basis of this new information, if anyone has any ideas for simple solutions or things I should try, I'd be most grateful to hear them. However, I am definitely no mechanic... :) so it looks like a trip to the auto-electricia may be needed.
 

·
Registered
Joined
·
2 Posts
Good afternoon, i have the same problem. All the module not working....i press any button and no light come on and the rear blower is working full but not response (i can´t turn off).
The fuses have been checked and the module connections too.
Does anyone know anything about this?
 
1 - 4 of 4 Posts
Top