RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #1
I found these little do dads located between the headlight and the headlight harness on the new parts car. I have no idea what they are or how they affect the headlights any help would be appreciated..

Thanks Scotty



 

·
LEGACY VENDOR
Joined
·
2,492 Posts
Yes it is HID bulb and ballast
 

·
LIFETIME CONTRIBUTOR
2002-2005 Range Rover MkIII / L322
Joined
·
5,424 Posts

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #5
I did after I posted my bad :oops:
So what is the long term affect if any using the system on the Rangi.. (BECM) issues?
Anyone know?

Scotty
 

·
Registered
Joined
·
18 Posts
hey scotty,
I used to have an HID kit in mine for about 3 years until i converted to the l322 lights. I had no BECM issues. However I've heard that if u use the cheaper HID kits, they might give u a "dip low beam error", due to the 35 watts instead of the 55 watts. I guess it has to do with the flicker harness. Any 1 else have any knowledge of this?
 

·
LEGACY VENDOR
Joined
·
2,492 Posts
2000_RR said:
hey scotty,
I used to have an HID kit in mine for about 3 years until i converted to the l322 lights. I had no BECM issues. However I've heard that if u use the cheaper HID kits, they might give u a "dip low beam error", due to the 35 watts instead of the 55 watts. I guess it has to do with the flicker harness. Any 1 else have any knowledge of this?
I do have the error for low beam and high beam. You get 1 message only after you lit them up, then you're fine.
I didn't have time to make an assy of electronics to solve the issue.
I tested many HID error free cables that are made for BMW or AUDI but it doesn't work on the Range Rover. BECM logic is different.
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #8
thanks you guys the little box says 55w and 85w on it..Turbo the A, B. C, and D pillars are covered in the 2000 rangi!
Sorry.. Hey I can send you that plug if you want it no charge. Your in France right :think: That would be intresting..
 

·
Registered
Joined
·
123 Posts
SCotty.. the reason for the error msg is because that set that you have there is a HI-LO bulb... when our cars use to separate bulbs for hi and low..

I am running the same kit on my truck however just the low and I do not get the error msg..

Its something you live with if you want a little for light coverage on the road.. My recommendations is to adjust the light beam a little lower as the HID kits are bright..
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
2,064 Posts
Discussion Starter #10
I haven't installed them yet, I just removed them from the parts car..
Thank you
 
1 - 10 of 10 Posts
Top