RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello i have a 2013 Range Rover evoque 49850 miles, coming to a stop the transmission has pretty harsh downshifts intermittently and sometimes makes a weird noise during downshift, dealer could not duplicate, I took a sample of trans fluid and it is black. Anyone experience this?
 

·
Registered
Joined
·
3 Posts
Apparently there are issues with the Evoque transmissions that the manufacturer or dealer won't tell you. I have a 2014 also with 49,000 miles that "bangs" into 2nd gear when shifting. Dealer had for 2 weeks and couldn't repair. Called factory rep out to look at it. Rep said the transmission had to "relearn" shifting. It is better but still noticeable. They said this is normal for Evoques.
 

·
Registered
Joined
·
336 Posts
If fluid is black - time to change it. While many oems say their fluid is lifetime - if you want a long life out of the transmission- changing fluid between 40-60k is a good idea.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Went round and round with dealer then contacted Land Rover got the transmission warrantied with alot of pushing
 

·
Registered
Joined
·
159 Posts
Sometimes "pushing " is what it takes. Something is overheating the fluid, whether it is a slipping clutch, band or friction plate, or the fluid is not being properly cooled by the cooling system. Make sure they properly checked the cooling tank in the radiator. Ray
 
1 - 5 of 5 Posts
Top