RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
165 Posts
Discussion Starter #1
Has anyone experienced a misfire or hesitation or vibrations during wet conditions NAS spec.?
 

·
SUPER MODERATOR
Joined
·
27,755 Posts
Could be a loose connection getting wet. Since you are under warranty I would have the dealer do a very detailed inspection of the issue.
 

·
Registered
Joined
·
3 Posts
Land Rover has just this week figured out what is causing this and has a team working on a fix.
Apparently, water is finding its way into the intercooler when the car is driven in the rain or left out in the rain.
If the car is only driven moderately, the water slowly evaporates and is gone after awhile.
But if there is water inside the intercooler and full throttle is applied, the rush of air from the turbocharger blows all the water at once out of the intercooler and into the intake, causing misfiring. Shut the engine off, restart it, and it will run normally until the intercooler gets water in it again.
Land Rover will announce a fix shortly which I will post here when I get it. They will probably campaign this fix to be done on every Evoque as they visit their retailers
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
165 Posts
Discussion Starter #4
I have experienced this condition on more than one instance. I was curious to hear if it was wide spread. Unbeliveable 50k for this crate! You might think it doesn't rain in the UK ! They had better make this right in a hurry! Bad news spreads fast in this business.
 
1 - 4 of 4 Posts
Top