RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter #1
I installed the GROM bluetooth module in my 2001 HSE a while back. I have the DSP system. The module works through the CD port and functions normally except I notice when streaming music from my iPhone most of the recordings sound distorted. Hard to describe but it sounds like the speakers are buzzing. This does not occur when using the FM radio at any volume. It also does not occur when I stream my music to other BT devices. There is not much to the install other than removing the CD plug and installing the GROM plug so not sure what is going on here. I did not install the AUX plug as I did not want to have to physically connect my phone. Any suggestions would be helpful.
 

·
Registered
Joined
·
1,493 Posts
Do you have the phone plugged in to power as a lot of USB chargers are very noisy. I've found the same when streaming music from a tablet, no problem if the tablet is running off it's internal battery but a buzzing noise if it is plugged into a USB charger.
 

·
Registered
Joined
·
1,295 Posts
Have you tried another iPhone? Have you tried reducing the output volume of your phone in case it's overdriving something?
 

·
Registered
Joined
·
131 Posts
Discussion Starter #4
Do you have the phone plugged in to power as a lot of USB chargers are very noisy. I've found the same when streaming music from a tablet, no problem if the tablet is running off it's internal battery but a buzzing noise if it is plugged into a USB charger.
Richard- Not plugged into power. Only using with internal battery.
 
1 - 5 of 5 Posts
Top