Range Rovers Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone!

New to this forum after having just bought my first ever RR!:) Two days ago I purchased my first RR - RR Sport HSE 2006. First thing I noticed is that I keep losing the GPS signal! It comes intimitedly and its ok for a few trips and then bang its gone.... I have seen a few threads saying its the antenna that needs replacing. Has anyone any other suggestions? Cleaning the contact points, any system reboots, callibration tips? I live in Norway so any references to e-bay or vendors in the US is a no no.

I would appreciate any documentation, photos, tips in 101 for Range Rover english as I am a newbie and please no Jargon that I will not understand.

If it really is in need of an antenna shift or upgrade of DVD, I would appreciate any European sources for this and any instructions would much appreciated!

Thanks in advance!

A very proud 1st RR owner :) :razz:
 

· Registered
2006-2009 Range Rover Sport
Joined
·
1 Posts
I have the same problem. My car (2008 RRS HSE Lux) displays the little GPS sign with a red line through it on the map screen. The car has had its battery disconnected for ~10 minutes (for other upholstery repairs) which did not change anything. The location difference varies wildly - all while within the Bay Area, it has pinned me as far as Ciudad Obregón in Mexico - almost 1000 miles off.

Looking for the same things as above - antenna location, necessary trim removal, probable causes. I have read through other similar threads and all of the information is either too vague, not relevant to my model, or contains dead links.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top